1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2006 Viano Parking sensor fault

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Big_boz, Mar 20, 2017.

  1. Big_boz

    Big_boz Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jan 7, 2017
    Location:
    Leeds
    Your Mercedes:
    Viano lwb 2.2cdi 2006
    Hello,

    Had the Viano for 6 weeks now and its proving to be an excellent family workhorse, in fact i have adopted it as my daily transport and shunned my nicer and newer cars.

    Will be doing a number of "nice to haves" to it over the coming months, but before that i seem to have an issue with the parking sensors that needs resolving.

    So when i come to a stop going forwards from time to time i get the 4 red lights and long beep and the PDC system switches off. This is almost always when its been raining, and dosent seem to happen in reverse.

    On a few occasions, i have seen the front left corner say i am about to hit something when there is nothing there and then the 4 lights, so on the balance of probability the front left is playing up. I know the previous owner (wifes uncle) and he tells me that he had all the rear ones replaced a few years ago as they were playing up but never had an issue with the front ones. I am inclined to believe him, so....is there any easy way to check whats going on?

    I would normally just listen to the sensors for the pinging noise, but Mercedes have been too clever and due to the system shutdown, i cant work out which one is faulty, or perhaps if the control unit is somewhere liable to getting wet in the rain. Any advice much appreciated
     

Share This Page