1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Glow plug light - comes on when engine hot 190D 2.5

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Adrianh1, Sep 28, 2008.

  1. Adrianh1

    Adrianh1 Senior Member

    Messages:
    95
    Likes Received:
    0
    Location:
    Hackney, London
    A year ago I had all five glow plugs renewed with new Beru glow plugs. The car starts well and runs smoothly in all conditions. However in the last 6 months the glow plug warning light has a habit of coming on when the engine gets very hot, typically when idling in traffic. It will then extinguish after a few seconds. There is never a problem with starting the engine or with the engine running. I'm wondering if it might be a faulty relay, as I'm pretty sure the fault can't be with the glow plugs themselves, given how well the car starts and runs.

    Any ideas?

    Many thanks

    Adrian
     
  2. wireman

    wireman Senior Member

    Messages:
    2,632
    Likes Received:
    0
    Location:
    lancashire
    Your Mercedes:
    nice 201 2.5D 1993 & very nice 129 SL500 1994
    I have not seen this one before, but would aggree and suspect the relay unit. There is only the relay and a temp sensor in the head which would be able cause the lamp to illuminate, the temp sensor adjusts the time that the lamp and plugs glow for.

    Open up the relay box and examine it for poor soldered joints on the PC board, it can be difficult to see but it might just be one solder joint becoming cracked/dry.
     
  3. OP
    Adrianh1

    Adrianh1 Senior Member

    Messages:
    95
    Likes Received:
    0
    Location:
    Hackney, London
    Thanks Wireman, I'll take another look at the relays here. Will report back in due course.

    ADrian
     

Share This Page