1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Have you had a problem that has been fixed by a forum post?

Discussion in 'General Mercedes-Benz Related Discussion' started by beccy, Apr 27, 2012.

  1. Alexsdad

    Alexsdad Active Member

    Messages:
    43
    Likes Received:
    15
    Joined:
    May 12, 2017
    Location:
    Suffolk
    Your Mercedes:
    2002 C270 CDI S203
    Thought I’d share a problem I had on my olde Mercedes, that thanks to the expert advice from others I fixed myself.

    I’ve got a 16 year old C270, and noticed I was getting a smell of diesel in the cabin of the car when driving slow, or at a junction, roundabout. I removed the plastic engine cover to see injector number 2 was spraying a fine mist of diesel, and the car started making a ‘chuffing’ noise, like a old steam engine.

    Seeing as this is the first diesel I’ve owned, I was well and truly out of my comfort zone on how to fix the issue. I started a thread on here asking the question, and the amount of answers I got within a short amount of time was unbelievable. Thanks to all involved for their help via this forum, and because of them I fixed the issue myself, only using £13 worth of parts. The information found on here is priceless, and extremely useful for someone like me who doesn’t mind ‘having a go’.
     
  2. xtriple

    xtriple Senior Member

    Messages:
    138
    Likes Received:
    9
    Joined:
    Feb 15, 2011
    Location:
    Torquay Devon
    Your Mercedes:
    208 Convertible 320. Vauxhall Astra estate (yuck!) Jeep Cherokee 4.0.
    So far this forum has saved me many pounds and I've only had the car a week! Bucket drains which I had never heard of were full of mud, brake light switch is faulty and I would have spent mucho dosh chasing a problem (BAS and ABS lights on) if not for the wise words from here.

    Thank you one and all :)
     
  3. The Pan Man

    The Pan Man Senior Member

    Messages:
    1,254
    Likes Received:
    0
    Joined:
    Sep 27, 2004
    Location:
    Warwickshire
    Your Mercedes:
    2008 E 500 A/G Classic colour combination.
    I have just noticed that the easy open i.e. all windows and sun roof ope off a prolonged press on the open button on the key is not working. I have had the battery off and can't remember ho to reset it. I have done all the windows and roof but they will not work off the fob. have I missed something? I can check the manual tomorrow but would prefer my memory jogged. Old age is not all it's cracked up to be.
     
  4. Capra

    Capra Senior Member

    Messages:
    1,917
    Likes Received:
    410
    Joined:
    Jan 27, 2018
    Location:
    Gloucestershire
    Your Mercedes:
    W204 2013 C350 CDI Pan roof
    Tunnel mode, didn't know it existed. Plus, loads of other really helpful questions answered. Not really a problem.
     
  5. mercmancdi

    mercmancdi Senior Member

    Messages:
    2,042
    Likes Received:
    191
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    Many times I have been guided on this forum and to be honest I probably would not be such a merc
    Nut today if it were not for the advice and thoughts of many members.
    I thank you all that helped ,and look forward to pestering you’s in the future,
    Have to add t v was very good to me
    Along with many others , too many to name.
     
    daibevan likes this.
  6. SmartAmg

    SmartAmg Senior Member

    Messages:
    377
    Likes Received:
    274
    Joined:
    May 19, 2018
    Your Mercedes:
    2011 E class coupe 350 CDI
    My 2011 E class coupe's
    windows squeaked going up and down, but only when wet, was advised spray the rubbers with silicone, hey Presto ! silence is golden :)
    Thanks for that.
     
    daibevan, mercmancdi and Capra like this.
  7. G.T.

    G.T. New Member

    Messages:
    4
    Likes Received:
    4
    Joined:
    Jan 29, 2018
    Your Mercedes:
    2009 220 clc cdi
    I had the windows of my 09 coupe tinted and then found the central locking did not work. The guys on here diagnosed the problem and I was then able to contact the mobile window tinter and explain the issue ( caused by the fluid he had used ). The guy then understood the consequences of his actions and resolved the issue.
     
    mercmancdi and daibevan like this.
  8. mercmancdi

    mercmancdi Senior Member

    Messages:
    2,042
    Likes Received:
    191
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    You were lucky they sorted it ,
    Some of the windows I have had done
    You would think they used a hose instead of a spray mist.
     

Share This Page