1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Iphone 8 Bluetooth problems

Discussion in 'General Mercedes-Benz Related Discussion' started by Jimmyd_uk, Nov 13, 2017.

  1. Jimmyd_uk

    Jimmyd_uk New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 13, 2017
    Your Mercedes:
    2014 C63 507
    Hi there, upgraded my IPhone to an 8 and IOS11. Phone connects to command alright but Bluetooth connection drops out ever minute or so and re-connects. Extremely annoying and affects the Sat Nav traffic. Also seems to happen with my Mercedes-me adaptor. Only started with the new Phone. Apple say it's not a problem. Anyone else experiencing any issues?

    Same week I also had my command system updated by Merc when I had a service! So not sure who's at fault.

    Cheers
     
  2. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    17,170
    Likes Received:
    4,085
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Sorry only got a 7+ on iOS 11 and that seems stable.
     
  3. Mr Filipov

    Mr Filipov Senior Member

    Messages:
    656
    Likes Received:
    109
    Joined:
    Dec 31, 2015
    Location:
    Huntingdon
    Your Mercedes:
    2014 BMW 530d Gran Turismo
    Mine is a 7 Plus on iOS 11 and will sometimes drop connection once in the first 30 seconds, reconnect and be fine there after.
     
  4. Sigoodall

    Sigoodall Active Member

    Messages:
    31
    Likes Received:
    5
    Joined:
    Jun 29, 2016
    Location:
    Southend on Sea
    Your Mercedes:
    A207 E220/2013/Diesel
    A couple of things to try:
    1) Are there any other phones paired with your Command unit? If so delete them an whilst you are in that menu delete your own phone and re-pair it with Command.
    2) Turn off your Wi-Fi whilst in the car. The phone will hunt for and try to connect to open Wi-Fi networks as you are grabbing live traffic data, and this may cause the Bluetooth connection to falter.
     
  5. OP
    Jimmyd_uk

    Jimmyd_uk New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 13, 2017
    Your Mercedes:
    2014 C63 507
    Thanks for the reply. Deleted all the phones from my command, even reset the system so been down that route. Also, reset everything on my IPhone as well. Good pointer towards turning off the Wi-Fi I'll give that a go and see ...... surprised no-one else is having an issue, looks like it might be my phone then.
     
  6. keefysher

    keefysher Senior Member

    Messages:
    2,387
    Likes Received:
    723
    Joined:
    May 4, 2007
    Location:
    Hampshire
    Your Mercedes:
    W166 GLE350AMG Line 3.0 2017. BMW Z3 2.8 1998.
    May be not everyone upgrades their phones when a new one comes out?? :shock:

    Having said that I did change my iPhone 6S Plus to an iPhone 8 Plus last week as my contract was up. I now pay less per month for more, and got £220 back on the old phone.

    When I realised I hadn't connected the new phone to the car as it has the same name having been backed up, it was easiest to delete the old one from Comand, then pair the new one. Took a few seconds. I use the Comand sat nag. Haven't connected Apple Car Play as my toons are on my iPod or stick or disc. I now put the phone in the armrest to charge on a USB with an Anker short cable (Anker recommend from Carl350 on here) and don't answer it on the move.

    There was great fanfare around the new function in iOs11 about the driving mode and you can choose not to have the phone on, or if a passenger tell the phone it's ok to answer calls / texts / e-mails etc, a better function would be to turn the effing thing off when driving, a more sensible use of technology. A number of companies are introducing no answering when travelling policies.
     
  7. Botus

    Botus Senior Member

    Messages:
    2,509
    Likes Received:
    351
    Joined:
    Jul 29, 2014
    Location:
    UK
    Your Mercedes:
    S500/2010/500
    I doubt your issue, but apple software has to be the worst thrown together by anyone.

    what a load of rubbish, randomware would be the best description,

    it was nasty and quirky before, but iOS11 takes it to another level (and all three updates since) it sees features randomly work and on photos one minute is swipe top to bottom the next its side to side...
     
  8. SunnyDee

    SunnyDee Senior Member

    Messages:
    477
    Likes Received:
    11
    Joined:
    Aug 29, 2011
    Location:
    West London
    Your Mercedes:
    C250 W204 Petrol Coupé
    my iPhone X works fine with my Command system, phone book comes up and I can stream music too without any issues. Mine also W204 face lift, I think its your phone dude...

    Also saying that my iPhone X works fine in my sisters BMW 116i F21 and the B Class too.
     
  9. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    17,170
    Likes Received:
    4,085
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    ^ ooooh get you with your iPhone X !!
     
  10. SunnyDee

    SunnyDee Senior Member

    Messages:
    477
    Likes Received:
    11
    Joined:
    Aug 29, 2011
    Location:
    West London
    Your Mercedes:
    C250 W204 Petrol Coupé
    haa haa.... a bit wast of £1140 though :eek:
     
  11. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    17,170
    Likes Received:
    4,085
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Good god! That’s an ABC strut!
     
  12. OP
    Jimmyd_uk

    Jimmyd_uk New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 13, 2017
    Your Mercedes:
    2014 C63 507
    Actually, I've been into Apple, they told me Mercedes are the problem, IPhone 8 uses Bluetooth 5 not Bluetooth 4. Their website says they don't support IPhone 8 or X

    upload_2017-11-19_9-3-37.png
     
  13. SunnyDee

    SunnyDee Senior Member

    Messages:
    477
    Likes Received:
    11
    Joined:
    Aug 29, 2011
    Location:
    West London
    Your Mercedes:
    C250 W204 Petrol Coupé
    You have a C63 right? I have C250 both W204 shape and face lift too?

    my X works fine and not once it ever disconnected. Perhaps delete all paird phones on your command system and start again?
     
  14. OP
    Jimmyd_uk

    Jimmyd_uk New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 13, 2017
    Your Mercedes:
    2014 C63 507
    Hi there SunnyDee, yip C63 507 - tried deleting everything off command, even reset. Also tried disabling Wi-Fi on the phone, still no luck. Works with IPhone 6 and 5 no problem. Picking up replacement Iphone8 at the weekend, see if that does the job... :)
     
  15. SunnyDee

    SunnyDee Senior Member

    Messages:
    477
    Likes Received:
    11
    Joined:
    Aug 29, 2011
    Location:
    West London
    Your Mercedes:
    C250 W204 Petrol Coupé
    Good luck... I strongly believe its your phone mate.
     
  16. Damian Davis

    Damian Davis Member

    Messages:
    10
    Likes Received:
    2
    Joined:
    Aug 6, 2017
    Your Mercedes:
    E63 AMG Saloon 2007
    Could be the fact that the 8 uses Bluetooth 5 ? My 8+ works fine but with a replacement head ...


    Sent from my iPhone using Tapatalk
     
  17. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,461
    Likes Received:
    693
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    Mercedes-Benz C32AMG, SL55AMG, C320CDI Sport Edition Estate and SLR McLaren Coupe Roadster.
    Its not the first time that MB have had issues with phones pairing with bluetooth. I remember blackberry being a nightmare when they were launched. MB eventually released a software flash of the comand to sort the issue out.

    Its definitely a hardware fault. More than likely down to your car hardware being made in 2010 (even though its a 2014 car) and your phone being made in 2017, thats a tech jump of 7+ years.
     
    Frosty149 likes this.
  18. Frosty149

    Frosty149 Senior Member

    Messages:
    2,197
    Likes Received:
    573
    Joined:
    Jan 9, 2017
    Location:
    Garden of England
    Your Mercedes:
    W207 '63 E350 coupe amg sport
    I can’t find the starting handle hole in the front grille...
     
  19. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,461
    Likes Received:
    693
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    Mercedes-Benz C32AMG, SL55AMG, C320CDI Sport Edition Estate and SLR McLaren Coupe Roadster.
    Put some hair around it....
     
    Flyinspanner likes this.
  20. stephaneLee

    stephaneLee New Registration

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jan 4, 2018
    Your Mercedes:
    C-Class/2012

Share This Page