1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sl500 R230 ABC Issue

Discussion in 'Suspension, Steering & Brakes' started by H24k, Dec 18, 2017.

  1. H24k

    H24k Member

    Messages:
    20
    Likes Received:
    2
    Joined:
    Feb 13, 2017
    Location:
    ENFIELD
    Your Mercedes:
    sl500 2002
    Hi Guys my sl500 r230 2002 Right hand drive has had the same problem since I bought it about 8 months ago which is the radiator fan is running constantly so have had to disconnect it and i have a red symbol on the water temperature gauge even when car is cold, and the warning low coolant visit workshop however the coolant is full!??

    The other issue I had was the central locking not working which was resolved with a recon pse pump, (not cheap!)

    But the main problem is the dreaded ABC warning and the front drivers side wheel arch being lower than the rest of the car and it pulls to the right when driving, ive allways had the same ABC symbol on the dash since I bought the car but its not the red one its the light blue or white message and it hasnt changed since ive owned it, Ive noticed that when I press the lowering button for suspension it defo lowers the car but takes a while, you cant actually see it lifting or lowering but after a while driving it becomes extremely stiff and bouncy but at the same time when i put into the lift up position the car seems to lift far too high and resembles a kangaroo! lol

    However at the moment its more in the Hyena look mode as the front right is lower down!

    I had a guy come down with star and we found the following code C1126-001 Fault in component B22/4 left front travel sensor however its the right side thats lower not the left unless you are standing at the front of the car looking towards the windscreen then it would be the left?

    No other faults came up regarding the ABC so im wondering if this would trigger the ABC message and stop the car from lifting correctly? Ive also noticed that when driving the car when turning round corners a bit fast I get the yellow triangle flashing for a few secs on the dash, so im not sure if this is linked?

    Ive not noticed any loss of fluid or any leaks from the struts etc!

    Any advice would be appreciated as I cant afford to take the car to garages and get ripped off however if i can locate the part then simply try and fit this myself!
     

    Attached Files:

  2. LostKiwi

    LostKiwi Senior Member

    Messages:
    12,183
    Likes Received:
    4,224
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Sounds to me like the valve block isn't operating as it should. They are rebuildable but make sure you use decent quality components (Craig on here can help).
     
    H24k likes this.
  3. AMGeed

    AMGeed Senior Member

    Messages:
    4,448
    Likes Received:
    811
    Joined:
    Jan 18, 2009
    Location:
    Poole, Dorset
    Your Mercedes:
    2004 W211 E55K ///AMG
    H24k and Flyinspanner like this.
  4. Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,045
    Likes Received:
    2,083
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
    Don’t ignore ABC warnings or Bad Things Happen.
     
    H24k likes this.
  5. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    14,643
    Likes Received:
    3,013
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    You might not have had noticed any fluid loss as it’s low or poor quality anyway.
    8 months ignoring any ABC warnings is incredible that your pump hasn’t imploded, and the valve block!
    DIY ABC work is really not recommended unless you are either an extremely good hydraulics engineer or a Mercedes specialist with specific ABC experience. As said above, contact Wayne Gates - sadly it’s going to cost money but every day driving it as it is, is nearer the day you will be looking at replacing both components....and that will be even more expensive!
    Or to summarise as Craig above “don’t ignore ABC warnings or Bad things happen”
     
  6. gramey

    gramey Senior Member

    Messages:
    637
    Likes Received:
    103
    Joined:
    Jul 23, 2016
    Location:
    Ipswich, Suffolk
    Your Mercedes:
    2003 SL350
    And there in lies the reason why I'm so reluctant to jump into an R230 as much as I love the look of them, my OCD with having things working properly wouldn't allow me to go 8 days with that warning flashing at me let alone 8 months! :)
     
    Spottydog, Gkinghorn and H24k like this.
  7. LostKiwi

    LostKiwi Senior Member

    Messages:
    12,183
    Likes Received:
    4,224
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Within 8 seconds I'd have it shutdown and waiting the big yellow taxi!
     
    gramey likes this.
  8. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    14,643
    Likes Received:
    3,013
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    I totally sympathise and recognise that. When I bought my 230 from Malcolm he told me the flappy paddle changers were inoperative, he and Cole had tried but couldn’t solve the issues - we both agreed we never used the blessed things and we agreed the sale. However my OCD got the better of me and I just couldn’t have something on the car not working!
    Move forward 8 months and I had a bill of 1k but operative paddles!
    The bills sadly didn’t stop there...
     
    gramey likes this.
  9. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    14,643
    Likes Received:
    3,013
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Is right Alastair!! Don’t understand anyone leaving it alone to be honest!
     
  10. drmw

    drmw Moderator

    Messages:
    3,586
    Likes Received:
    57
    Joined:
    Nov 25, 2007
    Location:
    Yorkshire
    Your Mercedes:
    SL63 AMG, prior to that A-M V8 Vantage, SL55, SL500 and many more
    Is the message "code C1126-001 Fault in component B22/4 left front travel sensor" not a clue?
     
  11. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    14,643
    Likes Received:
    3,013
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    You’d have thought so David- I don’t have Star but maybe someone who has could comment?
     
  12. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    14,643
    Likes Received:
    3,013
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    In saying that I did a code check on B22/4 on some of the old cr&p I had and that’s a plunger travel sensor.
    Would suggest a recalibrate on Star but the OP also describes a ‘kangarooing’ effect- that is more likely to be pump related surely ? (Was in my case and ended in a new pump)
     
  13. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    14,643
    Likes Received:
    3,013
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
  14. nicholas15

    nicholas15 Senior Member

    Messages:
    437
    Likes Received:
    89
    Joined:
    Dec 1, 2015
    Location:
    near Ashford, Kent
    Your Mercedes:
    s class w221 - 2012 350 Bluetec, SL500 r230 2003
    What could possibly go wrong with something so simple!
     
    John Laidlaw and gramey like this.
  15. alexanderfoti

    alexanderfoti Moderator

    Messages:
    9,552
    Likes Received:
    785
    Joined:
    Mar 25, 2010
    Location:
    West London
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG
    Is the radiator fan running full speed or slow when connected. That warning will come up when it's disconnected
     
  16. Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,045
    Likes Received:
    2,083
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
    And in my case, a new strut. The plunger travel sensors are internal...
     
  17. alexanderfoti

    alexanderfoti Moderator

    Messages:
    9,552
    Likes Received:
    785
    Joined:
    Mar 25, 2010
    Location:
    West London
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG
    +1
     
  18. alexanderfoti

    alexanderfoti Moderator

    Messages:
    9,552
    Likes Received:
    785
    Joined:
    Mar 25, 2010
    Location:
    West London
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG
    Leaking valve bodies cause this. The car sinks whilst the engine is running so it opens the valve, car goes up. Closes the valves, car sinks rinse repeat.
     
  19. m2287

    m2287 Senior Member

    Messages:
    239
    Likes Received:
    20
    Joined:
    Jan 6, 2009
    Location:
    Cambridge
    Your Mercedes:
    Bentley Continental GT - S55K AMG - RR vogue - Mazda6 estate
    Check the level sensor on that corner of the car. Disconnect it and make sure the arm is free, give it a good lube up then reattach.
     
  20. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    14,643
    Likes Received:
    3,013
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Indeed they are Craig- I was only commenting to what the OP had quoted as the fault code and part, think he’s run away now after reading some of the thread he’s created!
     

Share This Page