1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SL55 AMG 'Engine Oil Level. Stop, Engine Off!' help please

Discussion in 'AMG' started by daz10dazza, Dec 6, 2018 at 5:19 PM.

  1. daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Hi All,
    I must apologise for not posting for a long time, things have been so hectic with work and home life I haven't had the time to post, but, I do spend lots of time reading all sorts of threads on here, the information and knowledge you guys have is priceless !

    My old posts were about my E55 AMG, I still have it, had it for 7 years now !
    Its still the best car I have ever bought, the 113M engine is unbelievable, just turned 90k so guess its just run in lol. Seriously though its never let me down, yes its had a few general wear and tear parts replaced but reliability I cannot fault.
    Only issue I have now is the boot won't open, the motor failed so disconnected this to use manually (which I prefer tbh, the electrical motor is too noisy !) but guess the handle part has now failed to as cannot open at all, not even with the emergency key.

    Anyway I digress, sorry.....I have now just purchased an SL55 AMG 2004 model, covered 62k, beautiful machine...but, on driving home the other night the RED warning message as the title says came up, thing is does this mean oil level low ?? Its never said top up the oil once had that on the E55), I don't fully understand what the message means, if its low in oil surely it would say top up ?
    The oil level is fine and even says so, it generally comes up with this message after driving for approx. 30 mins and not always when driven hard, just general driving around town or A roads.
    I've read the oil sensor can be faulty, its going to my friends garage on Saturday where he'll plug it into STAR (he's an ex Merc technician working for himself) to see what it says.

    Just wondered if anyone's experienced this before, if they know what it actually means please.
    Thanks
     
  2. Wighty

    Wighty Senior Member

    Messages:
    4,448
    Likes Received:
    1,935
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    I wonder if it's got too much oil ? So after 30 minuites driving the oil expands and sets off the warning ?
    Have you got a dipstick to check it when it's hot after the warning comes on ?
     
  3. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Thanks Wighty for the reply, I don't have a dipstick, I've heard there not that good, guess your thought makes a lot of sense, wouldn't there be a warning message saying too much oil ? I don't know as never seen any messages like this before..
     
  4. Westheath

    Westheath Senior Member

    Messages:
    1,368
    Likes Received:
    404
    Joined:
    Nov 6, 2015
    Location:
    South London
    Your Mercedes:
    Empty garage, awaiting new toy :)
    Is this SL55 a silver one with a 5 digit personal plate in the Eltham area ?
     
  5. LostKiwi

    LostKiwi Senior Member

    Messages:
    14,467
    Likes Received:
    5,689
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    The simple fact it's a red message indicates it's a serious issue. I wouldn't start it until I knew what the cause was.
     
    Mic likes this.
  6. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Nope, its black with no personal plate...yet :)
     
  7. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Exactly that, thing is once the message comes up it then registers as a malfunction which I get, but once the cars been turned off this malfunction seems to reset itself and shows no malfunction, I would have thought such a serious message/fault would be logged as a malfunction until cleared/sorted ?
     
  8. LostKiwi

    LostKiwi Senior Member

    Messages:
    14,467
    Likes Received:
    5,689
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    You're trying to second guess the mentality of the programmer who developed the software....
     
  9. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Lol...I guess so, have had the odd fault before with the E55 (not an oil issue) and the malfunction message stays on until that faults cleared
     
  10. LostKiwi

    LostKiwi Senior Member

    Messages:
    14,467
    Likes Received:
    5,689
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    On my SL it stays on until key turned off unless it's an ECU recorded fault etc. Oil and bulb messages all turn off.
     
  11. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Ok thanks for this LostKiwi, at least I know this is normal now
     
  12. Westheath

    Westheath Senior Member

    Messages:
    1,368
    Likes Received:
    404
    Joined:
    Nov 6, 2015
    Location:
    South London
    Your Mercedes:
    Empty garage, awaiting new toy :)
    Ok
    I was on an 2004 SL55 with the same problem last week in Eltham, changed the sensor after checking on MB Star.
     
  13. AMGeed

    AMGeed Senior Member

    Messages:
    4,791
    Likes Received:
    1,019
    Joined:
    Jan 18, 2009
    Location:
    Poole, Dorset
    Your Mercedes:
    2004 W211 E55K ///AMG
    Don't take chances with a message like that.
    Unless you have adipstick to check it, assume the message is correct and you are very low on oil.

    I'd rough it and use the E55 until its been checked with Star:D
     
    LostKiwi likes this.
  14. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Thank you AMGeed, the sensor you changed was this the oil sensor ?
     
  15. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Lol...least I can rely on the E55 !!!
     
  16. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    Update on the message fauly. Took to my friend the Merc specialist, put the car on the lift to check the underneath to start, pleased to say all good. Plugged her into his Star machine, oil range was way out, the oil top level read 78 !!! Max should be 67 !!....so wasn't low on oil, infact he drained out 1.5 litres and rechecked as thats what he thought would bring the level down, it moved to 76...hardly any difference. So best thing was to drain all the oil and replace with exact amount, rechecked on Star and read 55....much better, so this equates to roughly 4 litres of over oil in the engine !!!!
    Will replace the oil level sensor on next service, I now know it has the correct amount.
    Thanks to all the replies and hope this helps others
     
  17. AMGeed

    AMGeed Senior Member

    Messages:
    4,791
    Likes Received:
    1,019
    Joined:
    Jan 18, 2009
    Location:
    Poole, Dorset
    Your Mercedes:
    2004 W211 E55K ///AMG
    8.5 litres is the correct amount for an oil change on a M113K engine
     
    Last edited: Dec 9, 2018 at 10:22 PM
  18. OP
    daz10dazza

    daz10dazza Senior Member

    Messages:
    181
    Likes Received:
    0
    Joined:
    Aug 21, 2007
    Location:
    Kent
    Your Mercedes:
    2003 E55 AMG Black
    This was on my new SL55 but same engine anyway, thank you. Just pleased I can now use the car and not worry, if the warning message comes on again know its the oil level sensor :)
    Only thing now is quite a large noise appears from the rear left side after driving for 30 ish mins, think the PSE pumps making this :(
     
  19. star

    star Forum Supporter Authorised Forum Supporter

    Messages:
    4,781
    Likes Received:
    269
    Joined:
    Oct 6, 2004
    Location:
    Reading
    Your Mercedes:
    Smart + others :)
    Are you sure all the oil was drained out at last oil change, it has two sumps and two drain plugs.
     
  20. ajlsl600

    ajlsl600 Senior Member

    Messages:
    1,792
    Likes Received:
    352
    Joined:
    Nov 18, 2013
    Location:
    france
    Your Mercedes:
    clk3202001,sl6002003 with everything,A class 170cdi auto

    well drain, sorry,suck out all the oil and refill it to the qty listed in the manual less half litre . give a run ,you should get yr answer , all this aggro to sort because some dipstick !! deleted the dipstick !! i had similar issue on clk if a little too much oil and aggressive cornering ,this would trigger limp mode ! took me a while to work that out.least clk has the blxxxy dipstick. stress caused by daft tech,if this turns out to be the issue .
    i would try the above ,before parting with cash for star test .
     

Share This Page