1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange issue, w203 not starting, stuck in park...

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Clockwork, Dec 8, 2018 at 10:14 PM.

  1. Clockwork

    Clockwork Active Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Feb 27, 2018
    Your Mercedes:
    None yet
    Since Thursday my C320 auto almost always won't start when I turn the key and won't even crank or turn over at all. It just does nothing

    However if I take the gear surround off, press the override button and force it in to drive then if I turn the key whilst moving it in to N at the same time it starts ok. Any ideas? Gear selector module?
     
  2. alexanderfoti

    alexanderfoti MBO Forum Supporter Authorised Forum Supporter

    Messages:
    10,291
    Likes Received:
    1,148
    Joined:
    Mar 25, 2010
    Location:
    Dartford
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG + Various other MB's
    Likely gear selector module reporting implausible gear. Get it on diagnostics and check the codes or actual values and see what you get.
     
  3. Uncle Benz

    Uncle Benz Senior Member

    Messages:
    2,230
    Likes Received:
    333
    Joined:
    Mar 31, 2006
    Location:
    West Sussex
    Your Mercedes:
    Mainly Mercedes
    I concur. Is it showing "P" on the dash when it won't start? Often it shows a blank when the selector module has gone faulty.
     
    alexanderfoti likes this.
  4. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,444
    Likes Received:
    686
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    Mercedes-Benz C32AMG, SL55AMG, C320CDI Sport Edition Estate and SLR McLaren Coupe Roadster.
    Not always, I would also check relay K in the front SAM. It can also cause exactly the same fault.
     

Share This Page