1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W204 hissing under bonnet with ignition on?

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Cossie7, May 20, 2017.

  1. Cossie7

    Cossie7 Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Mar 22, 2017
    Location:
    Lanark
    Your Mercedes:
    2010 c220 cdi
    Hi all,

    Has anyone noticed a hissing from under the bonnet with the ignition on?

    I know this will be the lift pimp but had plenty of diesels and yes you can normally hear the lift pump prime but this is quite a loud his as in if I didn't know better you would think it was spaying diesel everywhere (which it's not).

    Having starting issues and was wondering if this is normal on the w204 diesels?

    Cheers
     
  2. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    8,500
    Likes Received:
    936
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 AMG V8 Biturbo
    Have you checked the turbo hoses/pipes for any splits or bad connections?
     
  3. OP
    Cossie7

    Cossie7 Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Mar 22, 2017
    Location:
    Lanark
    Your Mercedes:
    2010 c220 cdi
    It won't start mate (long story), I hear the noise with ignition on

    Cheers
     
  4. OP
    Cossie7

    Cossie7 Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Mar 22, 2017
    Location:
    Lanark
    Your Mercedes:
    2010 c220 cdi
    No one with a 204 that can say whether there car does this or not?

    Thanks
     
  5. umblecumbuz

    umblecumbuz Senior Member

    Messages:
    2,496
    Likes Received:
    171
    Joined:
    Sep 20, 2010
    Location:
    Wales and Gozo
    Your Mercedes:
    S204 and CLC 204 cdi, other non-Merc machines
    Mine doesn't. Not much help really, but a definitive answer to your question.

    Umble
     

Share This Page