1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W211 Electronic Actuator

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Austy, Nov 7, 2018.

  1. Austy

    Austy New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 16, 2018
    Your Mercedes:
    1998 SL320 2003 CLK270CDI 2004 E320CDI 2006 CLS320CDI
    Hi

    Having an intermittant fault with the actuator, only happens if car has been moved quick from a standing start eg leaving a junction after which the car lacks power. Have had it diagnosed by my indy.

    Any advice on finding a replacement or repair service?

    2004 E320cdi straight six

    Thanks
     
  2. EmilysDad

    EmilysDad Senior Member

    Messages:
    6,400
    Likes Received:
    723
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    R320 2007
  3. OP
    Austy

    Austy New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 16, 2018
    Your Mercedes:
    1998 SL320 2003 CLK270CDI 2004 E320CDI 2006 CLS320CDI
    Thanks very much. Out of interest, did you have similar problem?
     
  4. EmilysDad

    EmilysDad Senior Member

    Messages:
    6,400
    Likes Received:
    723
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    R320 2007
    Randomly, the car would splutter & kangaroo when pulling away in a hurry ... other times it would be OK. What made me eventually get something done about it was when we were stranded, boxed in, in the middle lane of the motorway ... foot planted to the floor & we were doing 50mph
    http://forums.mercedesclub.org.uk/index.php?threads/new-turbo-alternatives.163932/page-4
     
  5. OP
    Austy

    Austy New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Mar 16, 2018
    Your Mercedes:
    1998 SL320 2003 CLK270CDI 2004 E320CDI 2006 CLS320CDI
    Mine has only presented the problem twice and was exactly the same as yours, foot planted and going nowhere, although both times had been after a quick getaway from a junction. I thought it was a kickdown issue but diagnosed as the actuator on its way out. Car has been fine this past few months to be honest.
     
  6. EmilysDad

    EmilysDad Senior Member

    Messages:
    6,400
    Likes Received:
    723
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    R320 2007
    I won't do any harm to open the electric side & give it all a good clean out out & check soldered joints. There's a picture here some where
     
    Wighty likes this.
  7. Wighty

    Wighty Senior Member

    Messages:
    4,237
    Likes Received:
    1,771
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    As Emily's Dad says , worth a look inside , there is some stuff on YouTube that explains that some of the small wires are prone to breaking loose . I recently took mine apart after a limp mode issue for 300miles . I didn't find any broken wires but there was a fair bit of carbon dust . I cleaned it out with electrical cleaner and on the advice of another member (Larkone) I put a tiny smear of high temp grease on the worm drive and wheels .
    Another thing I checked on my later E class , on advice of others was to check engine bay fuse F44 (15amp) which may have been an inlet port motor fuse and other connected items .
    Not saying for a Minuite that these are your faults but worth doing if you have the time and don't want to immediately spend the money . I also found you can get the actuators reconditioned for around £100 .
     

Share This Page