1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W221 losing driver assist functions

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Craiglxviii, Jun 14, 2018.

  1. Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,705
    Likes Received:
    2,498
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
    Hi all.

    Not my car this time, but a friend has just allowed me to persuade him that MB are the superior of the luxobarge makers and has moved over from BMW. He bought a lovely 221 S350L with all the gizmos this week. Palladium silver too.

    20 miles from home on his first commute and...

    My first thought was, wheel speed sensor but...

    The car sat for 6-8 weeks before sale so I also suspect a low voltage convenience battery.

    Any other thoughts? Btw he is in Northampton.
     
  2. Will Barber

    Will Barber Senior Member

    Messages:
    190
    Likes Received:
    11
    Joined:
    Jan 25, 2010
    Location:
    Cheshire
    Your Mercedes:
    CL 500
    Exactly the same as just happened with my CL (see post below yours). All driver assist related functions gone AWOL.
    I'm also waiting for some guidance. I cleared all the faults but they immediately returned.
    Regards Will
     
  3. OP
    Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,705
    Likes Received:
    2,498
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
  4. OP
    Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,705
    Likes Received:
    2,498
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
  5. alexanderfoti

    alexanderfoti MBO Forum Supporter

    Messages:
    9,994
    Likes Received:
    982
    Joined:
    Mar 25, 2010
    Location:
    West London
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG + Various other MB's
    I would still say wheel speed sensor. Has it been on diagnostics?
     
  6. LostKiwi

    LostKiwi Senior Member

    Messages:
    13,774
    Likes Received:
    5,201
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    As on the other thread. It sounds very much like one wheel speed sensor is sending a duff duff signal.
    A look using suitable diagnostic tools will soon show this.
     
  7. OP
    Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,705
    Likes Received:
    2,498
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
    No, not been on diagnostics yet, he only had it delivered yesterday and started driving it to work this morning. Poor sod.

    Thanks for the replies guys.
     
    alexanderfoti likes this.
  8. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    15,910
    Likes Received:
    3,561
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Sounds like the trend continues....
     
  9. alexanderfoti

    alexanderfoti MBO Forum Supporter

    Messages:
    9,994
    Likes Received:
    982
    Joined:
    Mar 25, 2010
    Location:
    West London
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG + Various other MB's
    It really is weird how they all fail like clockwork at the same age.
     
  10. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    15,910
    Likes Received:
    3,561
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Shame, straight back to the dealer then....
     
  11. OP
    Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,705
    Likes Received:
    2,498
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
    Private sale unfortunately, it wasn’t showing when viewed nor were there any error messages- I checked. Sod’s Law I suspect!
     
    John Laidlaw likes this.
  12. LostKiwi

    LostKiwi Senior Member

    Messages:
    13,774
    Likes Received:
    5,201
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    ^^^^^^
    This.
     
  13. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    15,910
    Likes Received:
    3,561
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Is indeed Alex, suspect some Dr. Evil type character is sitting somewhere having just pressed the button to activate this chain somewhere saying “ Unless you give me........one million dollars (gasp), I will disintegrate all MB speed sensors, ABS reluctor rings and.....” o_O
     
    alexanderfoti likes this.
  14. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    15,910
    Likes Received:
    3,561
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Wish we knew someone in the Northampton area with Star.....:cool:
     
    alexanderfoti likes this.
  15. OP
    Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,705
    Likes Received:
    2,498
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
    A, are you available on Sat for a quick Star hookup?
     
  16. Will Barber

    Will Barber Senior Member

    Messages:
    190
    Likes Received:
    11
    Joined:
    Jan 25, 2010
    Location:
    Cheshire
    Your Mercedes:
    CL 500
    It WILL be a wheel speed sensor related issue.
    I've just rechecked mine on the diagnostics, C0034 - Front RH wheel speed sensor.
    However, before splashing out it's always worthwhile checking that the modulator ring on the hub isn't either cracked or covered in shite as this would also bring a fault up.
    The modulator ring on the 216 and 221 are not toothed but have a smooth surface. So any tiny fracture, dent etc could throw up a light due to a broken signal.
     
  17. LostKiwi

    LostKiwi Senior Member

    Messages:
    13,774
    Likes Received:
    5,201
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Yep not problem. You coming to me?
     
  18. LostKiwi

    LostKiwi Senior Member

    Messages:
    13,774
    Likes Received:
    5,201
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    If only.... ;)
     
    John Laidlaw likes this.
  19. OP
    Craiglxviii

    Craiglxviii Senior Member

    Messages:
    12,705
    Likes Received:
    2,498
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Garage Queen; W211 E320 Avantgarde Estate Designo Edition
    He’s just dropped it at a garage near his work so will find out later. Let you know tomorrow if that’s ok?
     
  20. LostKiwi

    LostKiwi Senior Member

    Messages:
    13,774
    Likes Received:
    5,201
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Yep no probs. You have my number :)
     

Share This Page