Mercedes-Benz Owners' Forums  

 

Reply
 
Thread Tools Display Modes
  #1  
Old 15-10-2012, 06:49 PM
ghmd ghmd is offline
Junior Member
 
Join Date: Sep 2009
Car: ML320
Posts: 4
Default ML320 ECU random misfire!!!

Please help, my W reg ML320 is badly misfiring! It has been going on for months, I pull away and it goes into limp mode. I turn it off and the problem sometimes clears. On over-taking, it sometimes loses powere and this morning i nearly had an accident. We replaced the oxygen sensor and the problem still happens. I took it to the garage and the diagnostic was 'ECU random misfire'!
We replaced the MAF sensor and it improved for a while but now it is bad again. It is worse in damp and cold conditions. It is driving me nuts!! Please help!
Reply With Quote
  #2  
Old 15-10-2012, 06:51 PM
WG M-B WG M-B is offline
Authorised Forum Supporter
 
Join Date: Dec 2010
Location: North west london
Car: S210 E200 classic with rusty front wings
Posts: 2,328
Default

Can it not go on star to be checked by somebody???
Reply With Quote
  #3  
Old 15-10-2012, 07:48 PM
jibcl500's Avatar
jibcl500 jibcl500 is offline
Senior Member
 
Join Date: Oct 2005
Location: Cambridgeshire
Car: CL500,ML320,SLK280
Posts: 5,685
Default

Could be anything but unless it goes on star diagnostics your p!$$ing in the wind sunshine.

Coil packs?
plugs?
HT leads?
cats blocked?
O2 sensors?

Any dash lights?

jib
__________________
07 SLK280
95 C140 CL500
00 ML320
13 VW UP!
Reply With Quote
The Following User Says Thank You to jibcl500 For This Useful Post:
ghmd (31-10-2012)
  #4  
Old 15-10-2012, 08:11 PM
WG M-B WG M-B is offline
Authorised Forum Supporter
 
Join Date: Dec 2010
Location: North west london
Car: S210 E200 classic with rusty front wings
Posts: 2,328
Default

Very well put !!!
Reply With Quote
The Following User Says Thank You to WG M-B For This Useful Post:
jibcl500 (16-10-2012)
  #5  
Old 16-10-2012, 06:10 PM
jibcl500's Avatar
jibcl500 jibcl500 is offline
Senior Member
 
Join Date: Oct 2005
Location: Cambridgeshire
Car: CL500,ML320,SLK280
Posts: 5,685
Default

Your also not that far from me so if the ML can get here I can do a free yes free star diags for you, I also have a great many spare parts for the 320 so if we need something I should have it.

jib
__________________
07 SLK280
95 C140 CL500
00 ML320
13 VW UP!
Reply With Quote
The Following User Says Thank You to jibcl500 For This Useful Post:
ghmd (31-10-2012)
  #6  
Old 31-10-2012, 02:20 PM
ghmd ghmd is offline
Junior Member
Threadstarter
 
Join Date: Sep 2009
Car: ML320
Posts: 4
Default

Where are you? What is star? No dash lights
Reply With Quote
  #7  
Old 31-10-2012, 02:55 PM
jibcl500's Avatar
jibcl500 jibcl500 is offline
Senior Member
 
Join Date: Oct 2005
Location: Cambridgeshire
Car: CL500,ML320,SLK280
Posts: 5,685
Default

Quote:
Originally Posted by ghmd View Post
Where are you? What is star? No dash lights
CB6 3UL
Star diagnostics


jib
__________________
07 SLK280
95 C140 CL500
00 ML320
13 VW UP!
Reply With Quote
Reply

Tags
ecu random misfire ml320


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.