Mercedes-Benz Owners' Forums  

 

Reply
 
Thread Tools Display Modes
  #1  
Old 07-07-2011, 09:43 PM
racing 22 racing 22 is offline
Junior Member
 
Join Date: Oct 2010
Posts: 5
Angry SLK 320 engine cutting out

Hi
This is my first ever post so I'm hoping someone can help me.... I have an SLK 320 auto on a 53 plate - in the last few weeks the engine just cuts out with no warning! This can happpen at around 30mph or whilst stationary in traffic - all the ignition lights are on but the engine will just not turn over, the only thing I can say is strange is that the radiator fans are running when this happens but water temperature, coolant/oil levels are all ok. It was checked out by one of these diagnostic things and did show some faults which were then cleared but it has happened twice again since then and this time it will just not start - any help/advice would be greatly appreciated

Thank you
Janet
Reply With Quote
  #2  
Old 07-07-2011, 09:46 PM
television's Avatar
television television is offline
Senior Member
 
Join Date: Mar 2005
Location: West country by the sea
Car: CL216 with everything, CL420 140 with everything, V70R with everything
Posts: 136,616
Default

This does sound like the crank shaft sensor and they do not always show up on a test.

about 60 from Bosch and not too bad to fit

Welcome to the forum Janet
__________________
Malcolm

If you tell the truth, you don't have to remember anything.
Reply With Quote
  #3  
Old 07-07-2011, 10:05 PM
racing 22 racing 22 is offline
Junior Member
Threadstarter
 
Join Date: Oct 2010
Posts: 5
Angry

Quote:
Originally Posted by television View Post
This does sound like the crank shaft sensor and they do not always show up on a test.

about 60 from Bosch and not too bad to fit

Welcome to the forum Janet
Thanks for that Malcolm, could it be related to dampness due to the fact that the car has been used daily and there has been a lot of rain recently? Is this a common fault?
Thanks again
Janet
Reply With Quote
  #4  
Old 08-07-2011, 07:31 AM
television's Avatar
television television is offline
Senior Member
 
Join Date: Mar 2005
Location: West country by the sea
Car: CL216 with everything, CL420 140 with everything, V70R with everything
Posts: 136,616
Default

I was wrong on this please read the post from Alex below
__________________
Malcolm

If you tell the truth, you don't have to remember anything.

Last edited by television; 08-07-2011 at 09:17 AM.
Reply With Quote
  #5  
Old 08-07-2011, 08:12 AM
Alex Crow's Avatar
Alex Crow Alex Crow is offline
Authorised Forum Supporter
 
Join Date: Jul 2009
Location: Super Suffolk
Car: W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
Posts: 10,344
Default

i will go for the k40 on this one because...

it will not turn over on the key during fault condition
the fan runs at high speed suggesting loss of comms with the ECU
(the above would not be caused by crank sensor failure)
k40 type issues very common on these cars
__________________
ALEX CROW - Independent MERCEDES-BENZ Specialists
Reply With Quote
  #6  
Old 08-07-2011, 08:54 AM
television's Avatar
television television is offline
Senior Member
 
Join Date: Mar 2005
Location: West country by the sea
Car: CL216 with everything, CL420 140 with everything, V70R with everything
Posts: 136,616
Default

Quote:
Originally Posted by alexander patient View Post
i will go for the k40 on this one because...

it will not turn over on the key during fault condition
the fan runs at high speed suggesting loss of comms with the ECU
(the above would not be caused by crank sensor failure)
k40 type issues very common on these cars
You are of coarse right Alex,,I must learn to read better, its the new glasses
__________________
Malcolm

If you tell the truth, you don't have to remember anything.
Reply With Quote
The Following User Says Thank You to television For This Useful Post:
Alex Crow (08-07-2011)
  #7  
Old 10-07-2011, 08:11 PM
racing 22 racing 22 is offline
Junior Member
Threadstarter
 
Join Date: Oct 2010
Posts: 5
Default

K40 issue - is the K40 by any chance a small box within the ECU housing which has 4 - 5 relays and some fuses on the top? If so, yes, seems like the diagnostics guy found the problem - it turns out there were some dry joints on the circuit board and also a couple of hairline cracks so this has now been reparied - fingers crossed!!
Thank you for all your help - I'm now about to ask for more help on another problem - aaaaarrrrgggghhhh!! Will start a new thread
Janet
Reply With Quote
  #8  
Old 11-07-2011, 09:57 AM
Alex Crow's Avatar
Alex Crow Alex Crow is offline
Authorised Forum Supporter
 
Join Date: Jul 2009
Location: Super Suffolk
Car: W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
Posts: 10,344
Default

Quote:
Originally Posted by racing 22 View Post
K40 issue - is the K40 by any chance a small box within the ECU housing which has 4 - 5 relays and some fuses on the top?
that is the one, glad you got it fixed.
__________________
ALEX CROW - Independent MERCEDES-BENZ Specialists
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SLK 320 engine dies and wont start TWINSCREW Electrics, Vacuum, Ignition and ECU 8 22-12-2010 08:43 PM
Was the facelifted 170 series SLK and the SLK 320 made in yellow and AMG Styling? miurasv General Mercedes-Benz Related Discussion 7 05-11-2008 05:03 PM
2002 sl 500 engine cutting out steant Engine, Drivetrain, Fuel and Exhaust 1 18-02-2007 06:14 PM
Engine cutting out on 1986 300T Vic108 Engine, Drivetrain, Fuel and Exhaust 0 13-02-2005 03:40 PM
SLK 320 Power Windows raptur3 Electrics, Vacuum, Ignition and ECU 4 27-03-2004 03:32 PM


All times are GMT. The time now is 04:17 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.