03 Eclass 270cdi not starting

britespark

New Member
Joined
Oct 22, 2009
Messages
2
Reaction score
0
Location
Scotland
Your Mercedes
03 eclass 270cdi & bmw z3
My 2003 eclass 270i over recent months has displayed warning notice battery protection and that all functions are not available but after a a minute or so disappears. There has sometimes been a whirring noise when I have inserted the key in the ignition before starting. Now on turning the key nothing is happening other than the instrument cluster is bright red and the clock is whirring round. I have charged the battery but it appears to be fine.
Anyone got any ideas on what the problem is please? Will I be able to jump start the car to take to my local garage.
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
You have a flat battery, the clock is going around the wrong way yes?

I suspect its time to pay out of a new one!! Jump start "should" be ok!

Welcome to the forums!
 
OP
B

britespark

New Member
Joined
Oct 22, 2009
Messages
2
Reaction score
0
Location
Scotland
Your Mercedes
03 eclass 270cdi & bmw z3
  • Thread Starter
  • Thread starter
  • #3
I just bought a new battery last year that is why I am thinking that it is something else. I am unsure which way the clock was whirring round.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
as above. needs a charging and drain test.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome to the forum,,, you have several components that can fail to go to sleep and they can flatten the battery over night. They are the OCP,,a seat controller or the battery split box. with an ammeter joined into the circuit it would confirm this
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Add the switch panel (hazards, heated seats etc) to the list. No idea why but thats what ours turned out to be.

That would be the seat controller ECU
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Is that in the panel? I assumed that ecu was a black box under the seat somewhere..?

I am not 100% sure but I though that they were in the doors
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
mmm - in our case it was definately the switch panel. We still have the old one. Or at least thats what we were told......

OK thank you,,the next time I turn on I will take a look :D
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom