1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2007 S550 Rear View Camera

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by CocoPop, Nov 30, 2012.

  1. CocoPop

    CocoPop New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Mar 23, 2007
    Rear View Camera stopped working, came back on for a few days, then stopped permanently. AND one external rear view mirror sometimes fails to move out to normal driving position when engine is started. Just one of the mirrors - sometimes the driver's side sometimes the passenger side. Have individually tested all of the fuses in the five fuse boxes. All are O.K.. Also replaced the Rear View Camera relay located on the fuse board in the rear passenger compartment behind the armrest.

    Anyone got a clue as to the problem?
     
  2. Comand

    Comand Forum Supporter Authorised Forum Supporter

    Messages:
    437
    Likes Received:
    1
    Joined:
    Oct 11, 2012
    Location:
    Surrey
    Your Mercedes:
    ML63, SL55, A150, X5, Raptor, ZX10, ZRX1100, Mini, RD350B, RD250B
    Yes. the wire in the hinge from controller to the camera breaks. MB have a repair harness available. Symptoms are that reverse camera comes on but picture is blank.

    Mirror issue is probably the same (i.e a wires in the mirror breaking) - but no repair harness available (MB say replace mirror) you can just fix the cabling in the mirror if you dismantle it.

    Richard
     

Share This Page