2007 X164 GL320 airmatic malfunction

tony jr

Senior Member
Joined
May 5, 2009
Messages
581
Reaction score
9
Location
Nottingham
Your Mercedes
GL320 X164 2007
I have had the airmatic malfunction light come on and off for the last couple of weeks but the ride height was ok. Today I noticed the front suspension was at normal height but the rear suspension both side was about 60mm heightened than the front and feels hard. Any ideas what the problem could be or how to reset the system?


Sent from my iPad using Tapatalk
 
OP
T

tony jr

Senior Member
Joined
May 5, 2009
Messages
581
Reaction score
9
Location
Nottingham
Your Mercedes
GL320 X164 2007
  • Thread Starter
  • Thread starter
  • #2
Does anyone know if there is a rear axle ride height sensor that is independent of the right and left hand height sensors. I assume if either the right or left sensor failed that there would be a difference in height right to left not uniform as it is


Sent from my iPad using Tapatalk
 
OP
T

tony jr

Senior Member
Joined
May 5, 2009
Messages
581
Reaction score
9
Location
Nottingham
Your Mercedes
GL320 X164 2007
  • Thread Starter
  • Thread starter
  • #3
Do you think it could be moisture frozen in the valve block?


Sent from my iPad using Tapatalk
 
OP
T

tony jr

Senior Member
Joined
May 5, 2009
Messages
581
Reaction score
9
Location
Nottingham
Your Mercedes
GL320 X164 2007
  • Thread Starter
  • Thread starter
  • #4
Could it be one of the rear ride height sensors failed?
 

bembo449

Senior Member
Joined
Jan 2, 2012
Messages
6,072
Reaction score
2,813
Location
gainsborough , lincolnshire
Your Mercedes
Mercedes Cl500, shitron dispatch
you need to see if the rear height sensor is operating / still intact , not rotted off then go from there and have the codes read too
 
OP
T

tony jr

Senior Member
Joined
May 5, 2009
Messages
581
Reaction score
9
Location
Nottingham
Your Mercedes
GL320 X164 2007
  • Thread Starter
  • Thread starter
  • #6
Update: after riding around all week with the rear suspension locked in the high position and malfunction light on the dash the car decided to return to its normal level today all by itself! Now everything appears to be operating correctly. Could it have been frozen moisture in the valve block that has thawed?


Sent from my iPad using Tapatalk
 


Specialist Car Insurance provider in the UK offering cheap car insurance quotes for all risks including Mercedes cars.
Top Bottom