2011 S350 (W221) Suspension fault HELP!

MercMart0802

Active Member
Joined
May 16, 2009
Messages
33
Reaction score
3
Location
Southport
Your Mercedes
2011 S350 Bluetec Limo
My newest purchase is a delight! However since the second month of ownership, problem after problem.. and of course things that go wrong aren’t covered on the warranty provided.

I literally have just fixed a problem with the multimedia audio which turned out to be an amplifier problem, where water runs of boot arm down behind panelling and dripping into the amp.

The very same night I was driving home, drove over a speed bump and the car felt extremely funny within seconds... then every little bump bounced the rear end of the car around like someone had attached fleas rear legs to the car. I stopped to check and my rear airmatic suspension has extended to the top and is not/won’t return to normal height.
There is no suspension controls in the car just the Sport Airmatic button which hardens the suspension.

So, what I’ve done so far.....
Checked on snap on diagnostics.. no error codes
Have checked compressor functioning by undoing air line from it, stops and starts as should, somcompressor ok.
Spent an hour pulling out the area in the boot where I had re-fitted amplifier in case I’d done something.... nothing there that relates to suspension.

The current situation stands that Mercedes want £159 just to diagnose, possibly only needs recalibration, but they diagnose first then charge ‘on top’ accordingly.. it’s due in Monday but I’m trying to see if something I can do to save my £££.

Any help or suggestions ASAP greatly appreciated.. standing by for your responses
 

bembo449

Senior Member
Joined
Jan 2, 2012
Messages
6,072
Reaction score
2,813
Location
gainsborough , lincolnshire
Your Mercedes
Mercedes Cl500, shitron dispatch
Could be a height sensor ? Need to go on a ramp to spot it , they tend to sieze and break off pal
 
OP
MercMart0802

MercMart0802

Active Member
Joined
May 16, 2009
Messages
33
Reaction score
3
Location
Southport
Your Mercedes
2011 S350 Bluetec Limo
  • Thread Starter
  • Thread starter
  • #4
Well, what a frustrating but ultimately a productive afternoon....
Thank you for the suggestion be bembo449, after a quick look, I found the rod (pictured below) which links to the height level sensor broken. Somebody could really make some money making these in a better quality, £25 from Mercedes, and it’s a very cheaply manufactured part. However I was able to cancel the diagnosis £159 with Mercedes, + whatever they were going to charge on top... I bought a sensor just in case £125, but made sure I can return that if wasn’t the fault £££.
It wasn’t an easy job, but I’ve replaced the arm link on my driveway just jacking the car up... it can be done, but by god it was more difficult just removing clip and putting new one on.... being on here has paid off again... thanks again
 

Attachments

  • 50D69CB2-5D16-418B-996B-F16D144B2C53.jpeg
    50D69CB2-5D16-418B-996B-F16D144B2C53.jpeg
    112.2 KB · Views: 10
Top Bottom