1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2013 S212 rear wiper motor playing up.

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Crispian, Aug 13, 2019.

  1. Crispian

    Crispian Senior Member

    Messages:
    199
    Likes Received:
    84
    Joined:
    Nov 29, 2015
    Location:
    nuneaton
    Your Mercedes:
    E350 Amg line,Tvr chimaera.
    In the last month or so,the rear wiper on my 2013 facelift E class estate has started to have a mind of it's own.

    If I use the wash wipe or simply turn it on and off to clear overnight water,it stays on for roughly 5 minutes,pausing halfway between full strokes.

    Is this anything that anyone has experience of?

    A brief search of the internet suggests maybe the motor is full of carbon dust and is making it's own complete circuit through the dust/grease gunk inside?

    It brings up no codes on my Icarsoft MBII.

    Many thanks folks.
     
  2. Craiglxviii

    Craiglxviii Senior Member

    Messages:
    14,328
    Likes Received:
    3,670
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Motorway Queen; W251 R320L Familybenz, S211 E320 Avg Designo Edition now sadly missed.
    Could be that.

    The wiper drive on my S211 cost £45 and an hour of my time to replace...
     
  3. OP
    Crispian

    Crispian Senior Member

    Messages:
    199
    Likes Received:
    84
    Joined:
    Nov 29, 2015
    Location:
    nuneaton
    Your Mercedes:
    E350 Amg line,Tvr chimaera.
    Any suggestions as to where to get one?

    Cheers.
     

Share This Page