1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Airmatic compressor running

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by EmilysDad, Oct 19, 2012.

  1. EmilysDad

    EmilysDad Senior Member

    Messages:
    9,234
    Likes Received:
    2,762
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Just got home from work. As I opened the door, I could hear something running driver's side front wing ..... compressor kind of thing :confused::confused: Gave it a minute, still running ....... restarted the car ...... still running .... turned engine off ...... still running .........restarted car & raised the suspension on the Airmatic ....... still running ......... turned engine off .......... (there's a theme here ;)) still running. Poked around front off side wing & burnt my finger on the obviously hot compressor :cry: Pulled each relay ine at a time at rear SAM ......... still running. :confused::confused:
    I'd have pulled the battery leads if only I could get at the bu66er, so eventually partially moved wheel arch liner & pulled the plug from the compressor.
    I was getting a little worried for a moment because I could see what looked like smoke from the wing ...................

    Any thoughts? (obviously I'll phone MB in the morning :))
     
  2. whitenemesis

    whitenemesis Senior Member

    Messages:
    17,978
    Likes Received:
    22
    Joined:
    Dec 21, 2006
    Your Mercedes:
    CLS55 AMG '05
    I thought the airmatic compressor was under the near-side front wing?
     
  3. OP
    EmilysDad

    EmilysDad Senior Member

    Messages:
    9,234
    Likes Received:
    2,762
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    You might be right. I saw a compressor & assumed that it was for the suspension :confused: :confused: If it's not, I'm not sure what else it could be ........ :confused:



    I'll be back ...... off to see if the suspension raises ;)
     
  4. OP
    EmilysDad

    EmilysDad Senior Member

    Messages:
    9,234
    Likes Received:
    2,762
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Definitely the Airamtic pump. Only got as far as the ignition & the dash shows the car with the Airmatic 'up' arrow & 'Visit workshop' ;);)

    Any clue as to where the relay for it is - presuming it runs via one
     
  5. grober

    grober Senior Member

    Messages:
    2,941
    Likes Received:
    23
    Joined:
    May 15, 2002
    Location:
    Scotland
    Your Mercedes:
    W204 C200cdi estate
    Mercedes-Benz S430 Problem

    26 Reports


    Model Years Affected: 2000, 2001, 2002, 2003, 2004, 2005, 2006
    Average Mileage: 101,254 mi (13,600 mi - 200,000 mi)
    Verified

    The relay which turns the airmatic suspension pump on may fail causing the pump to run continuously. This can result in failure of the pump motor or a dead battery as the pump motor will continue to run after the car is turned off.



    The AirMatic Relay N10/1KR and 40amp fuse are within the fuse box in the engine compartment
     
  6. OP
    EmilysDad

    EmilysDad Senior Member

    Messages:
    9,234
    Likes Received:
    2,762
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Thanks Graeme That's great!

    I'll have a quick look tomorrow evening if it's dry, back in work all day again tomorrow....... & Sunday

    The car only has 47000 miles on it :confused::confused:
     
  7. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This was well known on the 220, I am surprised that they can still have these circuits where the relays cannot release, and just stay latched, a very poor design if this is the case, just like the relays on the sequencial gear box
     
  8. OP
    EmilysDad

    EmilysDad Senior Member

    Messages:
    9,234
    Likes Received:
    2,762
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Are the relays staying latched because they still have power on them ie being told to stay latched, or because the relay has failed & the contactor inside welding together? :confused:
     
  9. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This is a hard one, it depends much on how a relay is wired in. usually it is the relay its self that get damaged through overloading, or the rating not high enough, with excess heat and arcing of the contacts, this could give false information back to the circuit that asked for the relay to run. In all the cases that I have known the only cure has been a modified relay.
     
  10. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,571
    Likes Received:
    652
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    Open the front fuse box under the bonnet near slam panel, replace the green five pin relay, that's the one for the pump, Another common fault....
     
  11. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Would this apply Cole to the 219 CLS, as prevention is better than any cure
     
  12. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,571
    Likes Received:
    652
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    You dont have a 219 Malc??????
     
  13. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I know, but many others have :D
     
  14. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,571
    Likes Received:
    652
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    Ah right, yes, that relay is again green, o/s fuse box, at the rear of the Sam, not plugged into it tho, there is a plug on its own attached to the fuse box itself.....
     
  15. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Thank you very much and we can pass that info on when you are busy :D:D
     
  16. OP
    EmilysDad

    EmilysDad Senior Member

    Messages:
    9,234
    Likes Received:
    2,762
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Thanks.
    I haven't been ignoring you, I'm busy(-ish :rolleyes:) at work and have only just looked on line. I'll have a look tonight when I get home.
    MB weren't really that helpful ..... 'we really really busy & can't get your car in till a week on Monday!' :eek:
     
  17. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded

    Surprise surprise :shock::shock::shock:
     
  18. OP
    EmilysDad

    EmilysDad Senior Member

    Messages:
    9,234
    Likes Received:
    2,762
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Not really ..... :lol::lol::lol::lol:
     
  19. -raj-

    -raj- Senior Member

    Messages:
    129
    Likes Received:
    29
    Joined:
    Nov 11, 2008
    Location:
    Coventry
    Your Mercedes:
    SL350 SL55 SL63 E250 CDI
    Any update on this? exact same thing happened to my dad cls last night
     
  20. OP
    EmilysDad

    EmilysDad Senior Member

    Messages:
    9,234
    Likes Received:
    2,762
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    There's a bit of a tale to tell ........ :Oops:
    I tried a similar relay in place of the OE green relay I took out of the front SAM and 'things' happened - clicking etc from the front of the engine. The result was that the car would only run for 5 secs or so. A local indie kinda fixed it, but the Airmatic icon appears within a mile or so along with 'Vist workshop', which is where it is now. I was economical with the truth when I told MB what the problem was. :rolleyes::rolleyes:

    I'l let you know.
     
    Last edited: Nov 4, 2012

Share This Page