alarm starts intermittantly

coventryslk

Senior Member
Joined
Feb 3, 2009
Messages
1,414
Reaction score
79
Age
39
Location
Coventry
Your Mercedes
W204 CDI Sport
my alarm goes off on its own accord. Been going off more lately and its starting to irritate! Lockin doors with the key now. Any ideas whats setting it off?
 

bigasotonuk

Senior Member
Joined
Nov 14, 2006
Messages
5,315
Reaction score
43
Age
53
Location
Southampton UK
Your Mercedes
C43/55 AMG 1999 / C230K 1997
Hi,
Are your interior lights working correctly? inc. the boot, you could try checking the door and boot pin switches. Try turning the interior sensors off when you get out of the car as it has been known for tiny spiders and the like to get under the covers of the movement sensors (this is the case on w202s) and set the alarm off. Failling all this my next move would be to replace the alarm siren as when the car gets older the back-up battery in the siren fails, this is a very cmmon fault when i bought my new one it was about £55-60.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Problem in the boot PSE area I think,,and we have had our fair share of rain
 
OP
coventryslk

coventryslk

Senior Member
Joined
Feb 3, 2009
Messages
1,414
Reaction score
79
Age
39
Location
Coventry
Your Mercedes
W204 CDI Sport
  • Thread Starter
  • Thread starter
  • #4
pse? What is that and where in the boot is it?
 
OP
coventryslk

coventryslk

Senior Member
Joined
Feb 3, 2009
Messages
1,414
Reaction score
79
Age
39
Location
Coventry
Your Mercedes
W204 CDI Sport
  • Thread Starter
  • Thread starter
  • #6
the alarm sounds, and the lights flash too. Alarm goes off after a bit and lights continue to flash
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Have a look in the boot to see if there is any water anywhere, and take a good look around the roof/ locking pump, see if you can see any water marks or damp
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
the pse is in the o/s boot area low down (beneath the plastic trim) encased in foam. always worth checking for any sign of moisture in this area and check plugs etc for any corrosion.

definitely try locking with the interior motion and tow away sensors turned off (by pressing switch on dash) to see if this helps. personally i would read the fault codes first, but hey....................
 
OP
coventryslk

coventryslk

Senior Member
Joined
Feb 3, 2009
Messages
1,414
Reaction score
79
Age
39
Location
Coventry
Your Mercedes
W204 CDI Sport
  • Thread Starter
  • Thread starter
  • #9
no lights come on dash and i dont have an OBD diagnostic unit
 
OP
coventryslk

coventryslk

Senior Member
Joined
Feb 3, 2009
Messages
1,414
Reaction score
79
Age
39
Location
Coventry
Your Mercedes
W204 CDI Sport
  • Thread Starter
  • Thread starter
  • #10
no lights as in engine management fault lights etc
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
This fault will not put any lights on,,did you find any damp in the boot
 
OP
coventryslk

coventryslk

Senior Member
Joined
Feb 3, 2009
Messages
1,414
Reaction score
79
Age
39
Location
Coventry
Your Mercedes
W204 CDI Sport
  • Thread Starter
  • Thread starter
  • #12
no lights come on dash and i dont have an OBD diagnostic unit
 
OP
coventryslk

coventryslk

Senior Member
Joined
Feb 3, 2009
Messages
1,414
Reaction score
79
Age
39
Location
Coventry
Your Mercedes
W204 CDI Sport
  • Thread Starter
  • Thread starter
  • #13
no damp found. Dry and like new in the boot
 

bigasotonuk

Senior Member
Joined
Nov 14, 2006
Messages
5,315
Reaction score
43
Age
53
Location
Southampton UK
Your Mercedes
C43/55 AMG 1999 / C230K 1997
Hi,
You will have a diagnostic socket, on a 202 c class it is under the bonnet, in front of the passenger side of the windscreen. Not 100% sure on a SLK the exact position but most MB's are in this position but some i have been told are in the cabin somewhere.
 

antijam

Senior Member
Joined
Jul 20, 2008
Messages
1,619
Reaction score
64
Location
Gloucestershire
Your Mercedes
2003 SLK320
On the SLK the diagnostic socket is under the dash immediately behind the bonnet release lever. It is covered by a snap down lid.

To be of any use to you, you will of course need an OBD reader such as this for example.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
that obd reader will not do pse codes, i believe they only deal with engine management codes.

did you actually remove the pse unit in the place i described? this needs to be inspected carefully for damp and corrosion at plugs - the boot area itself may not show any signs of damp but the pse modules are very prone, on the 170, to water ingress.. also try locking without sensors, also as described.
 

bigasotonuk

Senior Member
Joined
Nov 14, 2006
Messages
5,315
Reaction score
43
Age
53
Location
Southampton UK
Your Mercedes
C43/55 AMG 1999 / C230K 1997
Hi,
If it is plugged into the MB diagnostic tool it gives you the ability to interogate the alarm system itself and it will tell you why the alarm system was triggered, i don,t believe you will get the this functionality with any other code reader.
 
OP
coventryslk

coventryslk

Senior Member
Joined
Feb 3, 2009
Messages
1,414
Reaction score
79
Age
39
Location
Coventry
Your Mercedes
W204 CDI Sport
  • Thread Starter
  • Thread starter
  • #18
can you clear fault codes with this? Ive noticed that if you lock the car with the remote by pressing it twice, the alarm is likely to sound, not right away though
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I still think that the rear SAM / PSE has a fault or the horn is short circuit,,disconnecting the horn first is the easiest thing to do
 

jp

Active Senior Members
Joined
Jan 15, 2003
Messages
163
Reaction score
1
Location
Wimbledon
Your Mercedes
2007 E280 sport estate. Aprilia RSV1000 Tuono, CCM 404, Mk1 le mans
Spider

My alarm went off a couple of times the other night for no apparent reason.
A couple of days later I found a small spider which I caught and evicted and the alarm hasn't gone off since!
A nice non technical answer for you...
 


GAD was founded in 2009 where we developed bespoke ECU Remapping software for motorsport clients, moving forward, we have extended to road vehicles for both performance and economy,
contact GAD Tuninghttp://www.GADTuning.co.ukto discuss your requirements.
Top Bottom