Auto Boot Opening Problem

Curikon

Active Member
Joined
Jun 25, 2009
Messages
34
Reaction score
0
Location
Bristol UK
Your Mercedes
2003 S55 AMG and 2002 ML500
Hello again guys n gals.

I've had some time now to get acquainted with my S55 W220. All is good bar a couple of slight niggles. The auto boot release only opens half way regardless of the setting using the comfort options. The other issue is that the heater seems to only blow hot air if the engine revs are raised above idle ie at tickover it only blows cool air. From experience this could be a blockage in the heater matrix or a poor water pump but I would appreciate any input you may have regarding either of these issues.

Other than the above I have to say I'm loving the whole MB experience! :D
 

Chas

Senior Member
Joined
Feb 23, 2005
Messages
729
Reaction score
2
Location
Scotland
Your Mercedes
S320
The auto boot release sometimes opens halfway on mine too. Lubricate the two large springs under the black plastic sheaths, and all the hinged parts including the lock.
The boot always opens fully on mine when the outside air temp is 20 c +. The metal bits work better when its not cold outside. Check the springs and all moving parts ( there are a few of them!) .The spring can be adjusted if need be

S320 :D

PS

if you are new to the S CLASS read the handbook section on climate control and air con. etc. The centre vent option is cold or auto (red light on wheel) and will blow cold air all the time if set to cold.(blue) I had to fiddle about with mine yesterday to stop the missus whingeing about the icy blast :rolleyes:
 
Last edited:
OP
C

Curikon

Active Member
Joined
Jun 25, 2009
Messages
34
Reaction score
0
Location
Bristol UK
Your Mercedes
2003 S55 AMG and 2002 ML500
  • Thread Starter
  • Thread starter
  • #3
Thanks Chas, I'll try lubricating the mechanism and let you know what happens. With regards to the climate, I'm sure I've set everything ok. Even if I set the system to defrost the air is cool unless I give the engine some revs. I might try flushing the cooling system in case there's a blockage somewhere. At least it's something to tick off the list of possibilities Come to think of it, it could just be an airlock. :idea:
 

HelpThisDude

Senior Member
Joined
Dec 2, 2008
Messages
649
Reaction score
5
Location
Essex
Your Mercedes
W203 C270CDI, R172 SLK55 AMG
If the S class boot opens with springs, like the C class, it might be worth trying new springs (for what they cost).

I had the same problem, even with the springs pulled back to the strongest setting it would not open fully.
New springs solved it, can't remember exactly how much they cost, but it was less then £15.
 

We are a completely independent Mercedes Benz service, Mercedes repair and Mercedes MOT centre located in Warrington, Cheshire and have been established since April 2006. All servicing carried out by MB Tech is in accordance with manufacturer service schedules and carried out by Mercedes Benz trained mechanics.
Contact MB-TECH on 01925 653050 or visitwww.mercedesservicingwarrington.co.uk
Top Bottom