C203 Seatbelt Reminder Passenger Seat Help!!

gilbem

New Member
Joined
Mar 27, 2009
Messages
4
Reaction score
0
I have a C203 (03 plate) and the passenger seatbelt warning (buzzer and warning message on driver informtion display) keeps activating whilst driving when the passenger seat is empty. I have temporarily fixed the problem by plugging the passenger seatbelt in but this method is very inconvenient when carrying passengers.

Does anyone know if there are any typical problems with the passenger seat. As it is a coupe it has quite a complicated opening mechanism that seems to to stress the harness under the seat.

I am cautious of unplugging any of the connectors under the seat to check them as I do not want to activate any airbag warning lamps. Also I do not know which conncetors are related to the occupancy sensor

anybody got any suggestions?? Can I get the dealer to disable this feature??:confused:
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes you have loose wires on the connector under the seat,,it is a well known fault
 
OP
G

gilbem

New Member
Joined
Mar 27, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Any idea which connectors/wires to fiddle around with. I have two black and two yellow.
I think the yellow are SRS related?

Car has manual heated seats on the passenger side
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Sparking plug info sent to you :D:D
 


ACMS Mercedes Ltd is an independent Mercedes-Benz service specialist based in Walsall. The company provides high levels of customer service and quality workmanship, at competitive prices. Call Mark on 01922 634666 or 07530 456000
Top Bottom