1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

C220 Wiper Problem

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by mercx2, Oct 18, 2012.

  1. mercx2

    mercx2 New Registration

    Messages:
    1
    Likes Received:
    0
    Joined:
    Oct 18, 2012
    Location:
    Leeds
    Your Mercedes:
    C Class
    Hi, I have a Mercedes C220 Avantgarde Diesel 55 plate, the wipers have developed a fault and I need some help to determine the part at fault. Currently when the wiper switch is turned to any speed setting nothing happens, the wipers don't move at all. BUT when I press the switch inwards for the washing fluid the wipers work (I think its 2 or 3 times as usual) with the water spray, therefore I know the motor is working properly.

    More Info:
    The car does have a rain sensor
    Indicators are working properly
    everything is working except the wipers on any speed setting.

    Thanks in advance for your help
     
  2. whitenemesis

    whitenemesis Senior Member

    Messages:
    17,978
    Likes Received:
    22
    Joined:
    Dec 21, 2006
    Your Mercedes:
    CLS55 AMG '05
    Sounds like the switch needs a clean?
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    A new stalk needed but try a clean with a no drying switch cleaner
     

Share This Page