Central locking issue 2002 c class coupe

Fatjames

New Member
Joined
Jan 14, 2022
Messages
4
Reaction score
0
Your Mercedes
W203 2002 C230 Kompressor
Hi,
I've read quite a few other threads on this, but still I'm having issues.
Symptoms:
RF lock / unlock from fob not working.

Eliminated:
Fuse 8 in the rear fuse box
Fob batteries

Other stuff:
Both fobs work when using IR and both work in the ignition.
The button in the car works.
The rear screen was replaced, the issues started mot long after. The glass firm have investigated with no joy and claim the glass and antenna are fine. (It did work OK after the glass went in, for a week or two)

Is there anything else I cam try? Ideally looking to DIY the repair (or for it to be cheap)

Car is a 2002 auto 2.3l petrol c class coupe with the double sub roof.

Thank you
 

Blobcat

Moderator
Joined
Feb 8, 2006
Messages
30,785
Reaction score
16,168
Location
Grange Moor
Your Mercedes
R171 SLK280, Smart R451, Land Rover 110 County SW, 997 C2S, R1250 GSA TE 40th, CBR600FP
Hello and welcome

Inside the key is a coil that can break off the circuit board in the key is dropped. The key will still work on IR and the chip is still read by the immobiliser, just the RF stops working.

If you’re handy with a soldering iron you can reattach it.
 
OP
F

Fatjames

New Member
Joined
Jan 14, 2022
Messages
4
Reaction score
0
Your Mercedes
W203 2002 C230 Kompressor
  • Thread Starter
  • Thread starter
  • #3
Hello and welcome

Inside the key is a coil that can break off the circuit board in the key is dropped. The key will still work on IR and the chip is still read by the immobiliser, just the RF stops working.

If you’re handy with a soldering iron you can reattach it.
Thanks, I'll give that a go (or at least have a look!)

I've seen some instructions on re-syncing, however they say from 2002 onwards. Do you happen to know the instructions for pre 2002? (What I've tried is: insert key, take it out, hold unlock for 10 secs and press lock twice)
 

Blobcat

Moderator
Joined
Feb 8, 2006
Messages
30,785
Reaction score
16,168
Location
Grange Moor
Your Mercedes
R171 SLK280, Smart R451, Land Rover 110 County SW, 997 C2S, R1250 GSA TE 40th, CBR600FP
Thanks, I'll give that a go (or at least have a look!)

I've seen some instructions on re-syncing, however they say from 2002 onwards. Do you happen to know the instructions for pre 2002? (What I've tried is: insert key, take it out, hold unlock for 10 secs and press lock twice)
If the IR is working then the key is synced to the car, no harm in trying though
 

mioba

Senior Member
Joined
Feb 19, 2006
Messages
5,112
Reaction score
2,413
Location
Nottingham and Köln
Your Mercedes
W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
if the issue os with both keys I doubt its the coil. Seems more on the car side.
 
OP
F

Fatjames

New Member
Joined
Jan 14, 2022
Messages
4
Reaction score
0
Your Mercedes
W203 2002 C230 Kompressor
  • Thread Starter
  • Thread starter
  • #6
if the issue os with both keys I doubt its the coil. Seems more on the car side.
I think so too. But I'm mot 100% convinced both keys worked before, so happy to eliminate something else.

I have a feeling the issue is somewhere between the pad that sticks to the glass and the fusebox. I can see fuse 8 is getting 12v, but not sure what to check on the glass. I get 12v at various places, but I know the heated screen is there too, so doesn't tell me much.
 
OP
F

Fatjames

New Member
Joined
Jan 14, 2022
Messages
4
Reaction score
0
Your Mercedes
W203 2002 C230 Kompressor
  • Thread Starter
  • Thread starter
  • #8
How’s the FM reception?
I think the two may share an amp.
I've read the amp is shared. Also read it's difficult to swap due to the connection to the glass.. even so, I can't see one on ebay anyway.

To add a complication..
FM signal is 'ok' but not great. I am using an aftermarket head unit along with a powered aerial splitter / DAB amplifier.
This was installed and working before the fobs stopped working. I had wondered if the splitter was causing the issue, but unplugging it (and the head unit) made no difference.
I've also wondered if I've somehow pumped 12v the wrong way towards the antenna and popped something.

The 12v feed for the splitter comes from back of the stereo (and is fused)

I wonder if there anyway to know if the car is receiving the RF signal? (to eliminate the window antenna from my investigations). For example, can I probe somewhere and watch for a rise or drop in current?
 

Stop looking for the Best Garage!! We are here and have the best advanced solutions for you, at Competitive prices. Put us to test with any issue you may have.
Top Bottom