1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CL500 Electric Problems (Drivers seat, Sunroof)

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by jwhelancarpentry, Mar 16, 2014.

  1. jwhelancarpentry

    jwhelancarpentry New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Mar 16, 2014
    Location:
    London
    Your Mercedes:
    CL500/2002/5.0-V8
    Hello there, i am new to this forum, thought it'll be good to pick the brains of the people who know the car well.

    The issues are, the drivers seat.
    Basically, i pulled the leaver to let someone in the back, the seat started moving forward, then i pressed on the door card button to pull it forward some more, and nothing happens. Went to put the seat back down, it doesn't slide back to where it was. Nor does the heated/cooled seats work, or any of the controls. I know there's power to the switch on the door, because when you press the bum warmer button, the red light is on when you press it,but when you let go, it goes off.

    I am thinking maybe a fuse? I have no idea where to start on this Merc, the wiring is very complex! So thats the main issue, however also a fault with the sunroof.

    I press the button for the roof, i can hear a relay ticking when i do so, so might be a mechanical issue? Help please!!

    Anyone else experienced anything like this?
    Anyone know where the fuses are for the drivers seat?

    Thankyou!

    Regards, Jim (a merc owner tearing his hair out trying to figure it out!)
     
  2. OP
    jwhelancarpentry

    jwhelancarpentry New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Mar 16, 2014
    Location:
    London
    Your Mercedes:
    CL500/2002/5.0-V8
    Fixed the seat!

    Fixed the seat!

    Now its the sunroof? Anyone shed any light? Regards, Jim.
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    289
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The roof motors have a 3 second stall if the roof is too tight, if you open the roof with the handle provided in the tool kit, you can lubricate the runners with Silicon or PTFE, not WD40 and it should work ok.
     
  4. OP
    jwhelancarpentry

    jwhelancarpentry New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Mar 16, 2014
    Location:
    London
    Your Mercedes:
    CL500/2002/5.0-V8
    Hi Malcolm, thankyou for your reply.

    I tried opening it manually like you suggested, it tilted fine, but the opening was so so stiff, i cracked it open about 2 inches, and physically could not open it any more, felt like there was an unhealthy amount of resistance. What would you do in my situation?

    Kindest Regards

    Jim
     
  5. Lexman8

    Lexman8 Active Senior Members

    Messages:
    882
    Likes Received:
    0
    Joined:
    May 14, 2013
    Location:
    Yorkshire, The French Alps & Quahog
    Your Mercedes:
    CL500 (2001): Distronic, Bose, Keyless Go; Honda CR-V EX (2011)
    How did you fix the seat?

    Thanks
     
  6. OP
    jwhelancarpentry

    jwhelancarpentry New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Mar 16, 2014
    Location:
    London
    Your Mercedes:
    CL500/2002/5.0-V8
    I fixed the seat by just changing the fuse.
    Its fuse number 66, under the rear seat (footwell)
    It was a 25a fuse that had popped, just replaced it, happy days.
     
  7. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    289
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    All one can do is to open it a little at a time and spray some PTFE in on to the tracks, in order to remove the cover the roof has to be fully open so that will no help
     

Share This Page