1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CLK 207 cdi. How can I reset the immobilizer?

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Mark_UK, Dec 10, 2013.

  1. Mark_UK

    Mark_UK New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Dec 10, 2013
    Location:
    London
    Your Mercedes:
    CLK 270 cdi (Year 2003)
    Hi everyone!!!

    Few days ago I spent all the day out, driving around London and my car was working perfectly. When I return home, I parked it and after 1h I came back to my car.

    I used the key as normal to open it, then I turn on the lights. But, when I tried to start the engine... the car completely switched off!!! Everything!! It looks like the immobilizer has been activated.

    I removed the battery, I put it back and again the lights inside and outside were working. I tried again to start it... same issue!!

    Does anyone of you have any suggestion???

    I much appreciate any comment any tip!!!

    Thanks guys!!!
     
  2. mersum1es

    mersum1es Senior Member

    Messages:
    1,956
    Likes Received:
    229
    Joined:
    Sep 25, 2010
    Location:
    Finland
    Your Mercedes:
    W212/-09/350CDI, W219/-07/320CDI, EX:W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
    Did you try (remote) lock the car, and then open it?

    Could be EIS problem too... or starter motor.

    Are instrument cluster light working? Buzz coming from EIS. Any noise from starter solenoid?
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Does the central locking work OK.

    Does the key turn in the ignition
     
  4. OP
    Mark_UK

    Mark_UK New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Dec 10, 2013
    Location:
    London
    Your Mercedes:
    CLK 270 cdi (Year 2003)
    Re:

    Hey guys,

    Thank you for your replies!

    Basically... I can open my car using the remote and everything works as normal... the seat belts move forward, the lights work on the dashboard... I can hear the noise when I insert the key fob. Now, when I try to start the car, this is when everything goes off.

    I remove the key, and if I try to use it again... the key would not turn at all. The car is completely off. This is like if the immobilizer has kicked in and blocked everything.

    At this point, I am trying to recharge the battery... as it was really low.

    PS. I can hear the typical noise coming from the motor when I turn the key into position 1. Problems start when I move into position 2.

    :(((((
     
  5. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Do try warming up the ignition switch with a hair drier and try.
     
  6. Mark@RMK

    Mark@RMK Senior Member Authorised Forum Supporter

    Messages:
    534
    Likes Received:
    8
    Joined:
    Jan 4, 2010
    Location:
    Birmingham
    Your Mercedes:
    115CDi Vito
    Heat doesn't affect any of the CLK EIS switches!

    If the Battery was low, sounds like its flat or dead to me!
     
  7. OP
    Mark_UK

    Mark_UK New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Dec 10, 2013
    Location:
    London
    Your Mercedes:
    CLK 270 cdi (Year 2003)
    Don't you think the problem is with the immobilizer? It seems like the immobilizer kicks in and switches everything off...
     
  8. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Any immobilizer cannot stop the key from turning to start
     
  9. alexanderfoti

    alexanderfoti MBO Forum Supporter Authorised Forum Supporter

    Messages:
    12,597
    Likes Received:
    2,842
    Joined:
    Mar 25, 2010
    Location:
    Tonbridge
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG + Various other MB's
    Another + for dead battery. The drain of the starter drops the voltage on the battery and the ecus switch off.

    You either left a consumer on, or your battery is duff or you have a parasitic drain.

    Sent from a mobile device
     

Share This Page