CLK Window Drop Problem

111Robin

New Member
Joined
Nov 1, 2009
Messages
5
Reaction score
0
Strange problem with my CLK windows. Exiting the car, the window drops as normal but when door is closed/locked, the window doesn't retrun to the closed position. If I close it manually from inside, then exit from the passenger side, the same thing happens with the passenger window. Can't think why this has started to happen, any ideas ?. Car is now sitting with either of the windows open a couple of inches and it's pouring with rain.
 
G

garysanderson

Guest
Have you tried holding the locking button (on door handle) down after you've exited? This should initiate full closure which *might* lift the window to it's closed position.

Hope that helps!
 
OP
1

111Robin

New Member
Joined
Nov 1, 2009
Messages
5
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Do you mean the handset locking button ?. I've read the thread on full closure so presume that's what you mean ?. I haven't tried holding it next to the door handle for several seconds yet, I'll try that next. I thought it might be a different issue as I'm not trying to close windows left open, it's happening without any input at all so figured it might be a fault in the system.
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
Malcolm will probably have come across this before. im sure it wont be long before he comes along with a reply

welcome to the forum
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
First thing to do is to re set the windows, by closing the window and holding up the button for 10 sec in Key2 .

This should solve the problem, unless the ECU is loosing count of the motor turns, or the window track that the glass go up and down in are too tight, and here a little PTFE sprayed in the track should solve it,,it will not hurt the paint
 
OP
1

111Robin

New Member
Joined
Nov 1, 2009
Messages
5
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
Thank's Malcolm, I'll try this first to see if it cures the problem,

Robin
 
OP
1

111Robin

New Member
Joined
Nov 1, 2009
Messages
5
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
It's worth stating that I have had the battery disconected to recharege it. The problem has only occured since re-connecting the battery. Is this likely to have upset the ECU ?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It's worth stating that I have had the battery disconected to recharege it. The problem has only occured since re-connecting the battery. Is this likely to have upset the ECU ?

You have answered your own problem :D taking the battery off the windows lost their stored settings, so just do what I said above after you refit the battery,,you will have the ESP lamp on too,so just turn the steering from lock to lock 3 times
 
OP
1

111Robin

New Member
Joined
Nov 1, 2009
Messages
5
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
Thank's again Malcolm, I'll give this a go,

Robin
 


A truly one stop site for Mercedes owners. Very experienced – friendly – down to earth – cost effective repairs offering either genuine or same quality parts so that you do not compromise your Mercedes heritage or reliability. Tel: 01406 422457fleetroadgarage.co.uk
Top Bottom