1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CLS 320 CDi miss-fire

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by concordepilot19, Oct 26, 2012.

  1. concordepilot19

    concordepilot19 Senior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Apr 29, 2004
    Your Mercedes:
    W204 (2013) C220 CDi Coupe, R129 (2001) SL 320
    Having not missed a beat during the year since I bought my CLS I was a bit gutted this morning when I started up as normal (waiting for the glow plug light to go out before turning over) and it was as rough as hell, only working on 5 cylinders is the best description. Drove 50 yards and then returned home.

    Switched off, re-started but no better. No warning lights and no glow plug light staying on or anything.

    MB Assist were there within 30 minutes and (of course) it started and ran perfectly smoothly. No question of a fuelling error as I always fill tank to full and only 1/4 remained.

    Extensive testing ensued with no fault codes and every parameter (e.g. injector performance) was bang in the middle of spec.

    Subsequently drove 210 miles with a few starts, no issues and 47.5 mpg.

    What is going on ?

    Technician said that taking the key out re-sets the computers, which of course I didn't do when I tried re-starting.

    Last re-fuelling was in Calais, surely not significant ?
     
  2. st4

    st4 Banned

    Messages:
    8,624
    Likes Received:
    2
    Joined:
    Apr 6, 2008
    Location:
    Sunny Scotland
    Your Mercedes:
    Disqualified driver
    I'd assume its an injector on the way out.

    The common IPS motor failure wouldn't deliver this behaviour.
     

Share This Page