CLS 320 Engine running rough

josh1

Registered
Joined
Nov 15, 2015
Messages
1
Reaction score
0
Location
london
Your Mercedes
CLS 320 Cdi 2006
Hi everyone and thank you in advance for any advice offered.

I own a 2006 CLS 320 (diesel) with some peculiar running issues.

1) Intermittently - On acceleration there is no acceleration for the first 1cm of throttle depression. Only a knocking noise from the engine. Pushing past this the car will accelerate well but seems to struggle / seem like it doesn't really want to go. Other times it will run like a dream.

2) Rough idle - also intermittent and coincides with problem number 1. The engine vibrates more than usual and can be felt through the car body. The exhausts shake too.

3) Cold starting problem - Recently replaced glow plug control unit following failure and fault code / dashboard light. Will turnover maybe 5 to 10 times, start and then produce a small amount of white smoke from the exhaust on first start of the day. Starts fine for the rest of the day.

4) Rumble from exhaust - if i tap the accelerator and certain RPM i get a resonance rumble / reverberation from the left exhaust (I think). Also reverberates / resonates at 2000RPM when accelerating.

Been on STAR at an indie with no codes displayed.

I'm thinking maybe an injector is dying?

Many thanks for any insight guys :)

Josh
 
Last edited:

WG M-B

Senior Member
Authorised Forum Supporter
Joined
Dec 5, 2010
Messages
3,105
Reaction score
6
Location
North west london
Your Mercedes
C63 Wagon in black
Does sound like an injector. You could have a leak off test done
 


Text: V4B offer competitive leasing deals across the Mercedes Benz range, we have excellent knowledge and experience on the Mercedes product and we pride ourselves on providing excellent customer service.
V4B
Top Bottom