Delayed start !!!

benzboySL500

Active Member
Joined
Jul 18, 2011
Messages
29
Reaction score
0
Location
london
Your Mercedes
2003 SL 500
In my 2003 SL 500 sometimes it has delayed start. Most of the times its fine though

Really frustrating !!!!!!!!!!!

Have changed spark plugs and fuel filter.

Anything else I can do?

Has this happened to anyone else?
 
OP
B

benzboySL500

Active Member
Joined
Jul 18, 2011
Messages
29
Reaction score
0
Location
london
Your Mercedes
2003 SL 500
  • Thread Starter
  • Thread starter
  • #3
yeh it starts first go 70% of time other times not...not sure if this is a known issue or what?
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,615
Reaction score
748
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, 209 240 CLK
Yes, we have a S,class which is doing the same, waiting the owner to leave it with us so we can get to the bottom of it.........
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Never known this on mine,its instant all the time
 
OP
B

benzboySL500

Active Member
Joined
Jul 18, 2011
Messages
29
Reaction score
0
Location
london
Your Mercedes
2003 SL 500
  • Thread Starter
  • Thread starter
  • #7
Funny thing is its not the weather, as I know cold engines can affect the start. This is more periodic in hot or cold.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
On a time scale how much cranking required when its not instant
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
OK, that is a long time, cannot think what it could be, see what Colin reports back with
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I had a S class doing this. Turned out to be the EIS switch.

I have been thinking Steve, could this be a dry starter ring, the op could check to see if the rev counter flicks up when it does not start
 

Steve@Avantgarde

Forum Supporter
Authorised Forum Supporter
Joined
Dec 8, 2009
Messages
7,040
Reaction score
1,332
Location
Bristol/Somerset
Website
www.avantgarde-automotive.co.uk
Your Mercedes
C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
I have been thinking Steve, could this be a dry starter ring, the op could check to see if the rev counter flicks up when it does not start

Could be Malc.....could even be the starter motor!!
 
OP
B

benzboySL500

Active Member
Joined
Jul 18, 2011
Messages
29
Reaction score
0
Location
london
Your Mercedes
2003 SL 500
  • Thread Starter
  • Thread starter
  • #15
Guys,

Problem fixed. Had to replace the front battery, as its close to end of life and all done !!!!!!
 
OP
B

benzboySL500

Active Member
Joined
Jul 18, 2011
Messages
29
Reaction score
0
Location
london
Your Mercedes
2003 SL 500
  • Thread Starter
  • Thread starter
  • #16
btw does anyone know why there are two separate batteries..one in front and one in back?
 

mikestrivens

Senior Member
Joined
Nov 21, 2008
Messages
2,715
Reaction score
146
Location
Stockport
Your Mercedes
1995 W124 320TE, 1998 R129 SL500, 2016 Triumph Tiger 800 XCx
The front one is purely for starting the engine. The back one is for all the other electrics. This way if the back one is low due to excess drain you can still start the car.
 


Welwyn Merx Limited is a family run business with genuine passion, dedication and 25 years of experience dealing with Mercedes-Benz and AMG passenger cars.
Tel: 01707 395999www.welwynmerx.uk
Top Bottom