Demister and aircon not working

john.james82

Member
Joined
Dec 11, 2016
Messages
13
Reaction score
0
Location
Mallusk
Your Mercedes
E350 Coupe W207 - 2010
Guys, there is no air coming from my windscreen demister or air vents. The air control unit turns on and you can increase fan speed and temperature etc but nothing happens.

Any idea were I looking to start looking to sort this?

Could the car need the air con refilled/regased? From search it seems that when this is required the air con will work but then switch off in 5-10mins. Mine stays on but there is no air.

Its a E350, 2010, C207.
 
OP
J

john.james82

Member
Joined
Dec 11, 2016
Messages
13
Reaction score
0
Location
Mallusk
Your Mercedes
E350 Coupe W207 - 2010
  • Thread Starter
  • Thread starter
  • #2
I've also just noticed that a very low humming sound can be heard when the air is switched on
 
OP
J

john.james82

Member
Joined
Dec 11, 2016
Messages
13
Reaction score
0
Location
Mallusk
Your Mercedes
E350 Coupe W207 - 2010
  • Thread Starter
  • Thread starter
  • #3
Update - I got myself a Carsoft MB ii scanner. It gave the below codes.

A10D21 the power supply is too low
90B349 electric heater booster 1 has a malfunction

Can anybody point me in the right direction to start investigating how to fix the air? I'm not having much luck with Google.

Also, I stupidity cleared the codes using the scanner. Now when i rescan there are no error codes. Is there a way to get these back. The code said "Stored".
 

mikestrivens

Senior Member
Joined
Nov 21, 2008
Messages
2,715
Reaction score
146
Location
Stockport
Your Mercedes
1995 W124 320TE, 1998 R129 SL500, 2016 Triumph Tiger 800 XCx
Probably got a leak in the system somewhere. The condensor at the front is a favourite as it gets hit with all the crud from the road. Need to get a dye put in the system to see where it is leaking.
 

Paul Goff

Senior Member
Joined
May 17, 2017
Messages
171
Reaction score
37
Your Mercedes
2002 C220CDi CD Estate
Guys, there is no air coming from my windscreen demister or air vents. The air control unit turns on and you can increase fan speed and temperature etc but nothing happens.

Any idea were I looking to start looking to sort this?

Could the car need the air con refilled/regased? From search it seems that when this is required the air con will work but then switch off in 5-10mins. Mine stays on but there is no air.

Its a E350, 2010, C207.


It is quite possible that a simple lack of airflow into the cabin is not related to the air conditioning per se!

If you are getting no air flow from some or all of the vents regardless of temperature setpoint and whether the air conditioning is switched on or off, you could have problems with the air control motors/flaps failing/sticking.

There is a set up/reset procedure for the flaps which you may be able to do yourself, however I do not know how to do it on your car, perhaps someone else can help with this?
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,501
Reaction score
15,957
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Also check the pollen filter isn't clogged. Its a common thing for them to be 'overlooked' when doing a service (but still charged for).
 


A truly one stop site for Mercedes owners. Very experienced – friendly – down to earth – cost effective repairs offering either genuine or same quality parts so that you do not compromise your Mercedes heritage or reliability. Tel: 01406 422457fleetroadgarage.co.uk
Top Bottom