1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dual Xenon light fault.

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by oldmedic999, Dec 23, 2012.

  1. oldmedic999

    oldmedic999 Senior Member

    Messages:
    112
    Likes Received:
    7
    Joined:
    Feb 5, 2011
    Location:
    Hertford Herts
    Your Mercedes:
    CLS 350 CDI 2010 3litre
    A couple of weeks ago a light warning came on the dash. It said Dipped beam right came on. Right Xenon was not working. Next morning when i started the car the light was working. Strange fault.
    Took car into the dealer as the car is still under warranty and booked it in for its service ( last free one). They came back to me and stated that found a fault but as the light was working it had cleared it self. Well the same problem happened on the way into work today. Took a photo of the dash and the lights, turned of the ignition for 15 minutes then started the car. Light was working again. Does any one have an idea what it may be?


    Thanks for your help everyone.


    Dom


    :rolleyes::confused:
     
    Last edited: Dec 23, 2012
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    It could be worth swapping the bulbs over , to see if is the same side going, if it is not then ballast or control unit.

    Do make sure the lamps are turned off, and do not turn them on with a bulb out
     

Share This Page