Engine starting issues and low power

j_kay

New Member
Joined
Jun 5, 2013
Messages
3
Reaction score
0
Location
leeds
Your Mercedes
2001 w203 c180
Hi all, This is my first post and my first benz purchase, im having a feel around after ditching BMW. i do like it but im having some issues and am hoping one of the pro's here can help me. i've read quite a few posts and couldn't find anything related exactly so decided to start a new thread.

the car is a auto box 2001 203 c180 160 miles classic converted to lpg

Ok, here it goes folks,
The engine would first when i bought it 2 weeks ago start after kicking several times, maybe 10 seconds. now its basically a nightmare, i will start but after many attempts, sometimes it will start on the 2nd attempt an sometimes on the fifth. The garage said it could be compression, but im not sure.

whilst driving if i put my foot down it doesn't make a difference it still carry's on accelerating at its own pace completely ignoring me for at least 7 seconds then it realizes my foot is fully pushed and gives the wallop. feels like the there is no power.

I would greatly appreciate any advice and guidance regarding these issues.

please note im no good with mechanics at the moment but am willing to learn.

Thanks for taking the time to read.
JK
 
OP
J

j_kay

New Member
Joined
Jun 5, 2013
Messages
3
Reaction score
0
Location
leeds
Your Mercedes
2001 w203 c180
  • Thread Starter
  • Thread starter
  • #2
adc

Just to add, after messing about with it for a while, it starts better in winter mode, sometimes after a few kiks and sometimes straight away on the second attempt. Thanks folks
 

BachelorDays

Senior Member
Joined
Feb 12, 2011
Messages
228
Reaction score
0
Location
Wandsworth, London
Your Mercedes
2000 w210 E240 91k (Nov13)
Presumably you are running it on petrol at present? If not, switch to petrol to test.

At that mileage and with those symptoms I'd start with fuel delivery.
 
OP
J

j_kay

New Member
Joined
Jun 5, 2013
Messages
3
Reaction score
0
Location
leeds
Your Mercedes
2001 w203 c180
  • Thread Starter
  • Thread starter
  • #4
zdf

Thanks I have fixed it, sort of, it starts fine in winter mode, so, i left it in winter mode and sold it for a nice profit.
Thanks for the help
 

Corned

Senior Member
Joined
Jun 25, 2012
Messages
1,470
Reaction score
5
Age
119
Location
East Midlands
Your Mercedes
2005 S211 E320CDI Avantgarde
^ That's one way of sorting out a problem! :lol:
 

Aitch55

Senior Member
Joined
May 21, 2012
Messages
166
Reaction score
1
Location
Bedfordshire
Your Mercedes
SL55 AMG
Thanks I have fixed it, sort of, it starts fine in winter mode, so, i left it in winter mode and sold it for a nice profit.
Thanks for the help

So some other poor sod will be asking the same question having been stitched up. Nice!
 
Top Bottom