Fan Problem

M

Marmite

Guest
Hi
I wonder if anyone can help?
I have a 1996 C200 and the fan (blower) doesn't work all the time. Sometimes it works and sometimes it doesn't. Neither hot or cold air can be felt from the vents and nothing happens when the dial is turned when it decides not to work. I'll then get in the car another time, turn the switch and it works fine. :confused: The problem has been there for the last month or so.

Any ideas?

Cheers
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
hi and welcome.

sounds like a faulty switch/loose connection or a sticking fan motor. im sure someone more knowledgeable about such things will be along soon
 
OP
M

Marmite

Guest
  • Thread Starter
  • Thread starter
  • #4
Thanks for your replies!

So does that mean I need a whole new blower motor?

I'm not technical you see. (Helpless female alert;))
 
OP
M

Marmite

Guest
  • Thread Starter
  • Thread starter
  • #6
Well I'll think I'll give the brushes ago first.

Thanks for your prompt help.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Well I'll think I'll give the brushes ago first.

Thanks for your prompt help.

You can buy them on Ebay circa £4 the reason why it is intermittent is that the air coming in turns the fan and it starts up
 

evobaz

Member
Joined
Jan 31, 2009
Messages
15
Reaction score
0
The correct brushes are available on ebay.

http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=190363120216&ssPageName=STRK:MESELX:IT

Be careful if you are attempting to use alternative brushes though (ie power tool brushes or washing machine ones etc) If they are the wrong grade of carbon then they can damage the commutator of the motor. If the carbon is too hard then it will wear the commutator and you'll eventually need a new motor. If the carbon is too soft then the brush will wear prematurely.

I fitted a set of these into my car and the heater has been working fine since.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thank you Baz it is a shame that they are not on Ebay all of the time
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom