faulty parking sensors

learnfast

Active Member
Joined
Jun 25, 2009
Messages
28
Reaction score
0
Location
South west
Your Mercedes
Sel 420
hello to u all i am new to this site any help in pointing me in the right direction would be very helpful.my parking sensors are going off when ever they feel like it.can any one advise please
 

Miffy

Senior Member
Joined
Sep 6, 2008
Messages
7,356
Reaction score
3
Location
Bromley, London
Your Mercedes
CLK 320 CAB Elegance C208
Hi and welcome. personally I dont know anything about them, but it might help those that do know, if you posted info on your car, model age etc etc
 

Blobcat

Moderator
Joined
Feb 8, 2006
Messages
29,112
Reaction score
14,575
Location
Grange Moor
Your Mercedes
R171 SLK280, Smart R451, Land Rover 110 County SW, 997 C2S, R1250 GSA TE 40th, CBR600FP
Could be a wiring fault or it could be an insect on the sensor
 

bigasotonuk

Senior Member
Joined
Nov 14, 2006
Messages
5,315
Reaction score
43
Age
53
Location
Southampton UK
Your Mercedes
C43/55 AMG 1999 / C230K 1997
Hi,
Welcome to the forum,
As Mark has said, car details are needed, and like Blobcat, ensure that all sensors mounted on the bumpers are clean. Has the car recently had any paintwork done? As the sensors could be U/S if they have been painted to excessively.
If you take the car to a STAR equipped independant, he should be able to interrogate the system and should be able to give a definitive answer to what is wrong, it can actually tell you which individual sensor is gone.
When I bought my C43, the PDC system was,nt working, it would come as soon as the ignition was turned on, and then turn itself off, and it turned out to be a loose connection on the main sensor loom for the front bumper, unplug, quick spray of switch cleaner and was perfect.
 


Specialist Car Insurance provider in the UK offering cheap car insurance quotes for all risks including Mercedes cars.
Top Bottom