Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
Hi, new to club . I have a Gle 350d p+ 2016 . Airmatic 23k miles
Please can someone direct me to a post regarding my problem.
I have read many threads and can’t find anything. The airmatic has malfunction.
No leak, not sagging, level . Not fuse or relay.
Normal first thing in comfort, until speed try’s to lower . Seems to be sat at one ride height . Can hear clicking/ tick ( pump? )
“Like can’t release air, to lower “
Please help ( star diagnostics next ) Lee
 

bembo449

Senior Member
Joined
Jan 2, 2012
Messages
6,326
Reaction score
3,034
Location
gainsborough , lincolnshire
Your Mercedes
Mercedes Cl500, shitron dispatch
first port of call is to get it on a diag machine , preferably star , then report back what codes are actually present
 

V6Matty

Senior Member
Joined
Aug 1, 2012
Messages
7,785
Reaction score
2,428
Location
Newark, Notts
Your Mercedes
S212/10/E350(His) W169/2005/A180 (Hers)
As above you need it on STAR to see what is actually upsetting the system.
I would at a guess suspect a level sensor that has failed and the car down know what height it is currently at
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #5
As above you need it on STAR to see what is actually upsetting the system.
I would at a guess suspect a level sensor that has failed and the car down know what height it is currently at
Thanks, that was what I thought.
Booked star in for Monday, guess each corner has level sens , or is there one central ? Seems stange car always sits level ,,more to follow...
 

V6Matty

Senior Member
Joined
Aug 1, 2012
Messages
7,785
Reaction score
2,428
Location
Newark, Notts
Your Mercedes
S212/10/E350(His) W169/2005/A180 (Hers)
Usually on each corner with airmatic if I remember correctly, could be wrong though and just be one front and back.
Are you booked in to MB or an Indy?
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #8
Usually on each corner with airmatic if I remember correctly, could be wrong though and just be one front and back.
Are you booked in to MB or an Indy?
Local independent specialist ( mercare)
 

V6Matty

Senior Member
Joined
Aug 1, 2012
Messages
7,785
Reaction score
2,428
Location
Newark, Notts
Your Mercedes
S212/10/E350(His) W169/2005/A180 (Hers)
Always a good start getting it to a trusted Indy, I’m sure I’ve heard of mercare, believe they have a good name for themselves.
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #10
Always a good start getting it to a trusted Indy, I’m sure I’ve heard of mercare, believe they have a good name for themselves.
£72 star , seems fair . Thanks for your advice. Read some posts about broken wire at pump , but at one point car fully raised , parked overnight, then back to normal level , so didn’t think pump . Need to get star done . More info.
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #11
Ok, so this mornings star results are:
N51/3 airmatic ..
C151E1C ( front left level sensor malf)
C156213 ( open circuit pump actuation)
B212500 ( power supply v ) “relay swap? “

The first event code mileage was basically when i collected from the dealer,
I guess they power washed under arch , so I’m going to look at left level sensor and wires tonight.
All fault codes printout,cleared as there are many many more , booked back in Thursday, as I left Indy , malfunction back on . Great at least it only shows what’s happening now .
 

Wighty

Senior Member
Joined
Aug 4, 2016
Messages
11,285
Reaction score
8,783
Location
Sunny Essex
Your Mercedes
W211/E320cdi/2009 and CLK200k 2009
Ok, so this mornings star results are:
N51/3 airmatic ..
C151E1C ( front left level sensor malf)
C156213 ( open circuit pump actuation)
B212500 ( power supply v ) “relay swap? “

The first event code mileage was basically when i collected from the dealer,
I guess they power washed under arch , so I’m going to look at left level sensor and wires tonight.
All fault codes printout,cleared as there are many many more , booked back in Thursday, as I left Indy , malfunction back on . Great at least it only shows what’s happening now .
Can’t the dealer repair it if that’s when it started ( if it’s more than a loose wire )
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #13
Can’t the dealer repair it if that’s when it started ( if it’s more than a loose wire )
200miles away , thier attitude was “ well you have the third party warrantee” let us know . It might go away .
Well time to give them the bad news .
Just a little annoying and inconvenient for me. Lol deep breaths
 

matthew k

Senior Member
Joined
Feb 4, 2015
Messages
691
Reaction score
265
Location
Winchester Hampshire
Your Mercedes
2005 320 cdi Sport 7 seat estate
200miles away , thier attitude was “ well you have the third party warrantee” let us know . It might go away .
Well time to give them the bad news .
Just a little annoying and inconvenient for me. Lol deep breaths
Their problem, 6 months statutory warranty. I'd leave it with them until it's fixed, otherwise they could take advantage of the distance. There's a 99% chance that third party warranty's worth less than the paper it's printed on.
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #15
I’m sharing this to highlight possible faults , not just for me but future users.. w166
So, back in today independent MB star number 2 after historic faults clear , few days drive .
Lots of fault codes as before: garage are saying “ at least two different fault lists “..conflict. They can’t say what is wrong.
Sam unit ( control unit issues ) .
Guy didn’t even know where any of the fuse boxes where , worked on so many models.
Think it’s a bit of a clue , or clueless.
I guess as most of Gle 16 have been under MB service for last 3 years, the independents just haven’t seen thier problems. MB it is then ! Or a 400m round trip . Back to dealers.
Gle 350 d malfunction, also realised today there is no C or S displayed ( dash display)
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #16
Their problem, 6 months statutory warranty. I'd leave it with them until it's fixed, otherwise they could take advantage of the distance. There's a 99% chance that third party warranty's worth less than the paper it's printed on.
I’ve always driven older Merc’s and others , just got to get into that way of thinking.Not my problem it’s theirs . Thanks for your support.
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #17
Dose anyone know where this terminal ends up ( the other end ) .
Pre fuse box , jump start unit .
Can anyone tell me if the two left terminals should have voltage ?
There is 12-14v off / running on right, both terminals side with fuse. Please
563EA15E-1055-42E3-B810-EB20A15D982B.jpeg
 

EmilysDad

Senior Member
Joined
May 8, 2012
Messages
10,450
Reaction score
3,782
Location
Bury Lancs
Your Mercedes
ML350
Should you not have a cover of some sort over that positive terminal? Mine has a sliding cover over it.
 
OP
Lee Edwards

Lee Edwards

Member
Joined
Jan 21, 2020
Messages
21
Reaction score
8
Location
Plymouth uk
Your Mercedes
Gle/2016/350
  • Thread Starter
  • Thread starter
  • #19
Should you not have a cover of some sort over that positive terminal? Mine has a sliding cover over it.
Yes I temporarily removed it to see if the pre fuse / fuses were visible.
You can slide back but there was no voltage on the terminal on the left , just visible under the cover . Can’t seem to find wiring diagram either.
 

jp williams

Senior Member
Joined
Apr 19, 2006
Messages
1,611
Reaction score
354
Location
Wirral & Axarqia,Spain
Your Mercedes
2002 E class 2.2 cdi auto estate, Lexus GS 450h
Their problem, 6 months statutory warranty. I'd leave it with them until it's fixed, otherwise they could take advantage of the distance. There's a 99% chance that third party warranty's worth less than the paper it's printed on.


Spot on.If you have had the car for less than 6 months, it is not a 3rd party problem.It is for the dealer to sort out at his cost.He should authorise a dealer close to you to fix.
 


Over 100 branches Nationwide, More than 114,000 Parts in Stock, The UKs Largest, and Fastest Growing Parts Supplier,please see MBO Members’ Area for discount codeEuro Car Parts Ltd
Top Bottom