1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Have you had a problem that has been fixed by a forum post?

Discussion in 'General Mercedes-Benz Related Discussion' started by beccy, Apr 27, 2012.

  1. Alexsdad

    Alexsdad Active Member

    Messages:
    43
    Likes Received:
    15
    Joined:
    May 12, 2017
    Location:
    Suffolk
    Your Mercedes:
    2002 C270 CDI S203
    Thought I’d share a problem I had on my olde Mercedes, that thanks to the expert advice from others I fixed myself.

    I’ve got a 16 year old C270, and noticed I was getting a smell of diesel in the cabin of the car when driving slow, or at a junction, roundabout. I removed the plastic engine cover to see injector number 2 was spraying a fine mist of diesel, and the car started making a ‘chuffing’ noise, like a old steam engine.

    Seeing as this is the first diesel I’ve owned, I was well and truly out of my comfort zone on how to fix the issue. I started a thread on here asking the question, and the amount of answers I got within a short amount of time was unbelievable. Thanks to all involved for their help via this forum, and because of them I fixed the issue myself, only using £13 worth of parts. The information found on here is priceless, and extremely useful for someone like me who doesn’t mind ‘having a go’.
     
  2. xtriple

    xtriple Senior Member

    Messages:
    138
    Likes Received:
    9
    Joined:
    Feb 15, 2011
    Location:
    Torquay Devon
    Your Mercedes:
    208 Convertible 320. Vauxhall Astra estate (yuck!) Jeep Cherokee 4.0.
    So far this forum has saved me many pounds and I've only had the car a week! Bucket drains which I had never heard of were full of mud, brake light switch is faulty and I would have spent mucho dosh chasing a problem (BAS and ABS lights on) if not for the wise words from here.

    Thank you one and all :)
     
  3. The Pan Man

    The Pan Man Senior Member

    Messages:
    1,254
    Likes Received:
    0
    Joined:
    Sep 27, 2004
    Location:
    Warwickshire
    Your Mercedes:
    2008 E 500 A/G Classic colour combination.
    I have just noticed that the easy open i.e. all windows and sun roof ope off a prolonged press on the open button on the key is not working. I have had the battery off and can't remember ho to reset it. I have done all the windows and roof but they will not work off the fob. have I missed something? I can check the manual tomorrow but would prefer my memory jogged. Old age is not all it's cracked up to be.
     
  4. Capra

    Capra Senior Member

    Messages:
    2,170
    Likes Received:
    505
    Joined:
    Jan 27, 2018
    Location:
    Gloucestershire
    Your Mercedes:
    W204 2013 C350 CDI Pan roof
    Tunnel mode, didn't know it existed. Plus, loads of other really helpful questions answered. Not really a problem.
     
  5. mercmancdi

    mercmancdi Senior Member

    Messages:
    2,242
    Likes Received:
    250
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    Many times I have been guided on this forum and to be honest I probably would not be such a merc
    Nut today if it were not for the advice and thoughts of many members.
    I thank you all that helped ,and look forward to pestering you’s in the future,
    Have to add t v was very good to me
    Along with many others , too many to name.
     
    daibevan likes this.
  6. SmartAmg

    SmartAmg Senior Member

    Messages:
    552
    Likes Received:
    395
    Joined:
    May 19, 2018
    Your Mercedes:
    2011 E class coupe 350 CDI
    My 2011 E class coupe's
    windows squeaked going up and down, but only when wet, was advised spray the rubbers with silicone, hey Presto ! silence is golden :)
    Thanks for that.
     
    daibevan, mercmancdi and Capra like this.
  7. G.T.

    G.T. New Member

    Messages:
    4
    Likes Received:
    4
    Joined:
    Jan 29, 2018
    Your Mercedes:
    2009 220 clc cdi
    I had the windows of my 09 coupe tinted and then found the central locking did not work. The guys on here diagnosed the problem and I was then able to contact the mobile window tinter and explain the issue ( caused by the fluid he had used ). The guy then understood the consequences of his actions and resolved the issue.
     
    mercmancdi and daibevan like this.
  8. mercmancdi

    mercmancdi Senior Member

    Messages:
    2,242
    Likes Received:
    250
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    You were lucky they sorted it ,
    Some of the windows I have had done
    You would think they used a hose instead of a spray mist.
     
  9. parkside

    parkside Member

    Messages:
    10
    Likes Received:
    4
    Joined:
    Jan 7, 2019
    Your Mercedes:
    1994 eclass w124
    My Windscreen wipers packed-in working as did my electric windows, after i had took my battery off (not sure it that connected) I asked on here and had a full weekend to carry out the sorting the problem. I was going to look at the motor the indicator arm and the relay. The last couple of post told me to look at fuse number 2, i had looked at the fuses before all looked ok. but hey for £1 for 9 new fuses. i took number 2 out put new one in BINGO. All working.
     
    daibevan and Capra like this.
  10. rexemper

    rexemper Senior Member

    Messages:
    617
    Likes Received:
    46
    Joined:
    Jan 5, 2007
    Location:
    Berkshire
    Your Mercedes:
    R230 SL500 - oh yeah!
    One of my keys kept showing 'Low Battery' when used in keyless mode - someone with a similar problem suggested unlocking and locking the car manually with the fob and the issue seems to be resolved. Wasn't a big thing but nice to have it fixed for free and with 2 minutes.
     
  11. Kev555

    Kev555 Senior Member

    Messages:
    102
    Likes Received:
    18
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    I had an on going issues with my W639 Vito for about 6 months which resulted in a breakdown just before Christmas. I had what I would call a fairly serious engine problem. Turned out to be injectors and a few other issues diagnosed by a few guys in the forum here (you know who you are) I was guided through the process by them and I am now back on the road for the first time in nearly two months and very relieved as I thought it was going to be looking for a replacement engine at the start.
     
    Last edited: Feb 10, 2019
    Uncle Benz and alexanderfoti like this.
  12. mimile

    mimile Senior Member

    Messages:
    48
    Likes Received:
    18
    Joined:
    Nov 4, 2018
    Location:
    Vendée, France.
    Your Mercedes:
    R 129 320 SL 1998 and w123 200D 1977
    I think most of us came to forums for technical help, and most of us stayed for friendly reasons.

    I'm on the main french mercedes benz forum since I bought my 129, eleven years ago, I did'nt have many troubles with it, however I discovered it was possible to meet other mercedes owners. Today some of them are good friends. We use to talk about everything else except cars.

    (Sorry for my English)
     
  13. LostKiwi

    LostKiwi Senior Member

    Messages:
    16,174
    Likes Received:
    6,848
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Your English is perfect.
    I wish my French was as good!
     
    Kev555 likes this.
  14. mimile

    mimile Senior Member

    Messages:
    48
    Likes Received:
    18
    Joined:
    Nov 4, 2018
    Location:
    Vendée, France.
    Your Mercedes:
    R 129 320 SL 1998 and w123 200D 1977
    I bet it is already... As far as I could read...
     
  15. RickC

    RickC Senior Member

    Messages:
    66
    Likes Received:
    19
    Joined:
    Jan 8, 2019
    Your Mercedes:
    C200 Compressor Estate 2006
    Absolutely. Not been a member very long and I have had a great deal of help.

    Thanks to all
     
    alexanderfoti and Wighty like this.

Share This Page