1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Have you had a problem that has been fixed by a forum post?

Discussion in 'General Mercedes-Benz Related Discussion' started by beccy, Apr 27, 2012.

  1. philreed52

    philreed52 Senior Member

    Messages:
    67
    Likes Received:
    17
    Joined:
    Jun 7, 2018
    Your Mercedes:
    270clk
    Hi I not only had a problem with my then newly acquired 270clk that my local garage mis diagnosed as "not worth fixing and will cost a fortune".This turned out to be an old battery causing 27 faults!I was about to put on Ebay spares and repairs and give up on my first ever MB ,nearly 2 years later and no other real traumas glad I came on forum. Don't get me wrong I know that older cars can be problematic but really very fond of this old beast especially as it is the last few months of the 270 clk (55 plate)
    Love the 5 cylinder lump (had Audi with 5 cylinders) like the engine drone ,so thanks everyone that helped and made me a MB fan.

    Sent from my SM-G950F using Tapatalk
     
    LostKiwi, Wighty and daibevan like this.
  2. Jim2

    Jim2 Senior Member

    Messages:
    1,057
    Likes Received:
    746
    Joined:
    Jan 18, 2018
    Your Mercedes:
    2010 Eclass w212 2.1 CDI
    Since I got my first MB ( 2010 w212 E Class ) in Jan 2018, ( my God,,,,it's nearly 2 years ago already....:eek: ) and joined the Forum, I can't praise ( or thank ) enough the help I have received from the member's since then. I'm not going to name them, or speak about the numerous problems they helped me with,,,would simply take to long. So here's a global all encompassing " Thanks You All" and here's to the future collaboration !!!:D:D:D
     
    AMGeed, LostKiwi, Wighty and 3 others like this.
  3. Wighty

    Wighty Senior Member

    Messages:
    9,196
    Likes Received:
    6,168
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    Roll on your next problem then Jim , so we can all club together and help :D
     
    Jim2 likes this.
  4. Jim2

    Jim2 Senior Member

    Messages:
    1,057
    Likes Received:
    746
    Joined:
    Jan 18, 2018
    Your Mercedes:
    2010 Eclass w212 2.1 CDI
    W
    Wighty, if you don't mind, the only report's I hope to make in the future would be along the lines of " And another 10'000 Miles trouble free Mercedes Benz driving " That's the plan anyway !!! ( but failing that, I know exactly where to find help !!!):D:D:D
     
    Wighty and Blobcat like this.
  5. Wighty

    Wighty Senior Member

    Messages:
    9,196
    Likes Received:
    6,168
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    That is something for us all to aim for :) !
     
    Jim2, RickC and SmartAmg like this.
  6. Rob Eggleshaw

    Rob Eggleshaw Member

    Messages:
    12
    Likes Received:
    4
    Joined:
    Feb 14, 2018
    Your Mercedes:
    190E 2.3-16 1986
    Yep - replaced plastic torpedo fuses with ceramic ones and electrics have been fine since.
     
    LostKiwi likes this.
  7. nesztler

    nesztler Member

    Messages:
    12
    Likes Received:
    3
    Joined:
    Jan 24, 2020
    Your Mercedes:
    ML400/2002/w163
    Hi,
    English is not my mother tongue, but it is a universal language that allows you to chat with the whole world. This is for this reason that I chose this one to get answers and help other people when I can. Recently, I did not know how to execute a task on my vehicle. Several people whom I thank again helped me.
     
    daibevan and Wighty like this.
  8. daibevan

    daibevan Senior Member

    Messages:
    1,192
    Likes Received:
    742
    Joined:
    Sep 29, 2015
    Location:
    Plymouth
    Your Mercedes:
    W203 C200 Kompressor Elegance SE 2006 Tanzanite Blue with cream interior
    Changed my thermostat today.
    Lord Lucan & others suggested jacking up the front of the car to reduce coolant loss.
    I drove up onto my ramps and emptied the reservoir with a syringe & tubing.
    When I took out the thermostat housing I lost less than an egg cup full of coolant.
    Top Tip.
     
    Blobcat likes this.
  9. crippo2

    crippo2 Senior Member

    Messages:
    286
    Likes Received:
    65
    Joined:
    Mar 9, 2014
    Location:
    North Oxfordshire
    Your Mercedes:
    SL350 (R230) & CLK350 (W209)
    Oil weep to top nearside rear of M272 engine on 2007 SL350 correctly identified within hours by the forum gurus as likely leakage from one or more of the plastic Expansion plugs (Cam Caps) Even pointed me to a Utube vid.
    Part Nos: A0009985690 (small 30mm dia) and A0009986590 (large 65mm dia) are on order from MB Newcastle.
    Thanks Guys
     
    John Laidlaw and LostKiwi like this.
  10. Oonnzo

    Oonnzo New Member

    Messages:
    4
    Likes Received:
    1
    Joined:
    Jul 5, 2020
    Your Mercedes:
    2010 W251 OM642
    I’ve had a Turbo chatter problem that has been baffling me for a few months now and have been scouring worldwide forums. After a few hours of posting here I’ve discovered it is “normal” with other people having the same issue!

    Thanks and look forward to being a part of the community (from Australia) :)
     
    daibevan likes this.

Share This Page