1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Heated rear screen on SL panaoramic not working.

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by roadster198, Nov 28, 2012.

  1. roadster198

    roadster198 Guest

    My R129 1998 SL320's rear heated screen appears to have given up the ghost. When it's switched on only a few lines appear to be working and basically gives up. Any ideas?

    Thanks
     
  2. NW_Merc

    NW_Merc Banned

    Messages:
    801
    Likes Received:
    0
    Joined:
    Apr 27, 2008
    Location:
    Oop Norf
    Your Mercedes:
    Mercedes W202
    Is this the screen on the folding roof or hard top?
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    There is no element in the soft top window, thats impossible as it folds in order to go into the boot.

    If the lamp is staying on the full 15 mins, and just a few elements working there is a break. These screens are very low power and not very effective even when working. A repair kit may work, and as the hard top comes off they are easy to work on.
     
  4. OP
    roadster198

    roadster198 Guest

    I've had a mechanic look at it and there is power getting to the roof... his concern is that it could be the glass itself that's the problem. I assume a replacement pain for the hardtop will be very expensive?

    To be fair I asked him for a quick assessment so as not to impose to much cost.
     
  5. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    If the lamp is staying on it shows the control unit as latched to the relay that operates the screen, you have the connector in the passenger door B pillar, you can measure for 12v there and you can do a resistance check on the plug that goes to the glass window element.

    As I said earlier the screens are not very effective, they are too low a wattage.

    t
     
  6. mikestrivens

    mikestrivens Senior Member

    Messages:
    2,715
    Likes Received:
    146
    Joined:
    Nov 21, 2008
    Location:
    Stockport
    Your Mercedes:
    1995 W124 320TE, 1998 R129 SL500, 2016 Triumph Tiger 800 XCx
    Yes on mine I find that the aircon is better at clearing the inside of the rear window than the heated element.
     
  7. mikestrivens

    mikestrivens Senior Member

    Messages:
    2,715
    Likes Received:
    146
    Joined:
    Nov 21, 2008
    Location:
    Stockport
    Your Mercedes:
    1995 W124 320TE, 1998 R129 SL500, 2016 Triumph Tiger 800 XCx
    And the car heats up quickly enough to clear the outside pretty quickly as well.
     
  8. OP
    roadster198

    roadster198 Guest

    New battery bought and the rear screen seems to be trying a little harder but not much more than that.... :sad:
     
  9. stevieb15

    stevieb15 Senior Member

    Messages:
    142
    Likes Received:
    0
    Joined:
    Feb 13, 2010
    Location:
    West Sussex
    Your Mercedes:
    98 r129 sl500,90 W126 500SE,03 CLK 320 Avant Convertible
    I looked at this thread yesterday and thought it wrong, but as its been months since I used the hrw on any car decided not to comment in case my memory failed me.
    But this morning with two cars sat on the drive under 3 degrees of frost I was able to perform a direct comparison test between the SE and SL...within 3 minutes the SL was clear whilst the SE was a work in progress.
    It may be a case of the SE hrw being utterly useless but as I've always been quite impressed with the SLs ability to defrost I'll stick with my view its rather effective.
     
    Last edited: Nov 29, 2012
  10. OP
    roadster198

    roadster198 Guest

    The new battery has certainly improved it's performance a little however it's clearly not right. I've e-mailed the SL shop and I'm still awaiting a reply....
    They've been good with a couple of other issues so I hope they can sort something out...
     

Share This Page