heater problem

petermalone

New Member
Joined
May 9, 2009
Messages
6
Reaction score
0
just bought a 04 E270 but heater does not work , blows but not hot
i have felt the pipes and only warm and they dont seem to have water in
HOW DO YOU BLEAD THE PIPES
:confused:
 

Xtractorfan

Senior Member
Joined
Nov 16, 2007
Messages
6,084
Reaction score
156
Your Mercedes
S class
What temp does the guage read when the car is fully warmed up, If the header tank is showing correct levels when the car is standing then the problem is more likely to a sticking thermostat or duovalves...
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
What temp does the guage read when the car is fully warmed up, If the header tank is showing correct levels when the car is standing then the problem is more likely to a sticking thermostat or duovalves...

No duo valves in this one, well I cant see them, no pump either
 

5pares

Senior Member
Joined
Feb 25, 2005
Messages
224
Reaction score
0
Location
Suffolk
Your Mercedes
E320cdi
I suspect it will be the valves that sit under the master cylinder at fault.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I suspect it will be the valves that sit under the master cylinder at fault.

Possible but they always fail in the hot mode, ie no voltage going to them
 


Save 30% on RAC Breakdown Cover
This year...next year... and every year you stay with RAC
Prices start from only £35.35*
This offer is available to all MERCEDES CLUB members and their immediate family**
Top Bottom