Help. Stuck in 2nd gear.

rbatt

Member
Joined
Oct 18, 2009
Messages
10
Reaction score
0
Help. My 2000 C220 is stuck in second gear. It got stuck in 4th last week but it corrected itself when I restarted the car. The tiptronic type gear change doesn't work and the gear indicator just remains on "D".

My instrument cluster has pixel problems so I cannot read it properly. But there are no orange light or warning triangle.

I've got the AA coming in the morning.

Any ideas??
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I have answered your other post and this should just be the speed sensor plate that has failed
 
OP
R

rbatt

Member
Joined
Oct 18, 2009
Messages
10
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Thank you. Easy to obtain and fit? Expensive or pennies?
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
About £350 fitted by an indie
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Some do it for £300 do ask first
 
OP
R

rbatt

Member
Joined
Oct 18, 2009
Messages
10
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
I also posted on the electrical part of the forum. Someone suggested low oil levels. My pixel don't work but there have been some random warning chimes at different speeds. Would low gearbox oil produce a warning chime?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I also posted on the electrical part of the forum. Someone suggested low oil levels. My pixel don't work but there have been some random warning chimes at different speeds. Would low gearbox oil produce a warning chime?

No sir they would not
 

miknik

Member
Joined
Mar 19, 2005
Messages
10
Reaction score
0
Location
Berkshire
Website
www.mercanix.co.uk
Your Mercedes
Vito 111CDI LWB
I also posted on the electrical part of the forum. Someone suggested low oil levels. My pixel don't work but there have been some random warning chimes at different speeds. Would low gearbox oil produce a warning chime?

No, but nor would a faulty speed sensor on the electrics plate. My money is on the speed sensor, 9/10 times this is the problem. Parts cost is about £140 for a new electrics plate, you might as well do the oil and filter while you are in there.
 
OP
R

rbatt

Member
Joined
Oct 18, 2009
Messages
10
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
AA man didn't have a fault code reader!

He reckons that it's the torque convertor?? Due to the way that the gearbox clunks into 2nd gear.

Anyway it's off to my local indy behind the AA van
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
AA man didn't have a fault code reader!

He reckons that it's the torque convertor?? Due to the way that the gearbox clunks into 2nd gear.

Anyway it's off to my local indy behind the AA van

I doubt it very much
 
OP
R

rbatt

Member
Joined
Oct 18, 2009
Messages
10
Reaction score
0
  • Thread Starter
  • Thread starter
  • #11
Indy just called. Speed sensor problem (as suggested on this forum). Approx £320 fitted.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Indy just called. Speed sensor problem (as suggested on this forum). Approx £320 fitted.

Just put it sown to bad luck,,and that price is good and OK
 

Stop looking for the Best Garage!! We are here and have the best advanced solutions for you, at Competitive prices. Put us to test with any issue you may have.
Top Bottom