1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

indicators on 1984 107 500SL

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by LA222222, Sep 12, 2013.

  1. LA222222

    LA222222 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Sep 12, 2013
    Location:
    Gloucestershire
    Your Mercedes:
    R107/1984/500
    Use of indicators is causing the instrument panel and the electric windows to fail. Some suggestions as to where and what to look at first would be much appreciated. thanks.
     
  2. OP
    LA222222

    LA222222 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Sep 12, 2013
    Location:
    Gloucestershire
    Your Mercedes:
    R107/1984/500
    further info

    I see that the warning systems, speedo, windows, brake lights, indicators and hazards are all on the same circuit and indeed they all fail simultaneously. The fault is intermittent but can generally be overcome by restarting and then either use of hazards, indicators or brake light trips it again. I am hoping someone savvy is going to tell me that I just need to replace the relay under the hazard switch. thanks
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The first thing to do on a car of this age is to remover the fuses one by one and spray the end contacts with a good non drying switch cleaner (Maplins) and replace revolving them as you go and try the car
     
  4. OP
    LA222222

    LA222222 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Sep 12, 2013
    Location:
    Gloucestershire
    Your Mercedes:
    R107/1984/500
    television, spot on, the fuse looked and tested ok but the brace was not making good contact,, thanks.
     

Share This Page