I've de-splined my wiper arm!

AlastairD

Senior Member
Joined
Jul 6, 2010
Messages
512
Reaction score
0
Location
Birmingham
Your Mercedes
2004 S211 E270 CDi Elegance 100k+
I've recently been trying to adjusting my wiper arms so it doesn't park on the rubber on the 211. My first attempt was to adjust both arms on the LH blade, this had no effect and it seemed to have a memory and still parked on the windscreen rubber.

My second attempt was to just adjust the outer arm of the mechanism this seemed to work for a while but then it went back to parking on the rubber again.

I think the last adjustment must have put excess strain on the inner arm and this morning it failed 'de-splining' it in the process.

I've filed some ribs in it and put it back on but not sure how long its going to last! Better call spares - again!

Couldn't find any adjustment process on WIS BTW.
 
Last edited:
OP
AlastairD

AlastairD

Senior Member
Joined
Jul 6, 2010
Messages
512
Reaction score
0
Location
Birmingham
Your Mercedes
2004 S211 E270 CDi Elegance 100k+
  • Thread Starter
  • Thread starter
  • #2
Hand filed spline repair work seemed to do the trick, made it 30m home in the rain no problem. I've also managed to get if to park off the rubber so hopefully no more annoying smear across the rain sensor (which was the original problem).

I think I'll leave it alone now, and keep a spanner in the boot in case I ever need to take it off.
 

b1g1an

Senior Member
Joined
Dec 12, 2012
Messages
224
Reaction score
0
Your Mercedes
CLS55 AMG
On mine at least you need to do the nuts up a lot lot tighter to get them to lock on than other cars I've had and my splines are fine.
 


ALL MBO Club members qualify for 15% discount on second hand parts.Please see MBO Members’ Area for discount codewww.dronsfields.com
Top Bottom