Loss of power

Mysterious_stranger

New Member
Joined
Jul 18, 2009
Messages
4
Reaction score
0
Hi, i need help.

I very recently bought a v reg mercedes c250td auto
At low speed, the vehicle is fine and pulls away, but since driving on the motorway, there is a considerable loss of power, with no kick.
Once i reach over 75mph is seems limited.
No smoke is coming out of the exaust, therefore i'm assuming the turbo is ok.
The car revs up, but does not want to give me accelleration.
Will I end up damaging the engine if not fixed?
 
Last edited:

jberks

Senior Member
Joined
May 12, 2004
Messages
11,146
Reaction score
25
Location
M1, Outside lane, somewhere between Leeds and Lond
Your Mercedes
Jaguar XF 3.0 S, LR Freelander 2, Fiat 500 & Fiat Panda
Probably won't damage anything but it's not right clearly.
Sounds like the ECU is shutting things down - normally because it doesn't like what it's hearing from a sensor. It it doesn't believe the readings it will put the engine into a default safe mode - with the result that you have no power and no kickdown. If your car has a MAF (Airflow sensor) it will probably be that.
Anyway, get a merc specialist to take a look. Probably nothing serious.
 


The SL SHOP YOUR ONE STOP SHOP FOR ALL THINGS SL, SERVICE & RESTORE, SALES, HIRE & PARTS
Choose from a wide range of superbly prepared SL’s each with a 12 month guarantee. We can service, update, re-trim, restore and repaint your 107 SL.
Choose from a 6 or 8 cylinder car for the day, the weekend, a month or a year. Contact us for a wide range of parts. Tel: 0844 414 2116 or visit our website atwww.theSLshop.com
Top Bottom