miles to service problem

xavierx

Senior Member
Joined
Sep 16, 2009
Messages
237
Reaction score
0
Your Mercedes
2004 W211 E320 CDi
Hi guys and gals,

My W211 E class behaves a little strangely when it comes to telling me how many miles to the next service.

It was serviced 1000 miles ago by the previous owner, and now sometimes it says "service D in 12431 miles" At some point in the journey it will then say "service D in 7233" and then if it is feeling particularly strange it changes over to saying "service D in 7233k/m" ... I certainly hope is is not due in 7233k/m!!

Any ideas anyone? or is the famous E-class electrics I was warned about ;)

Many Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Maybe its testing you out :D:D possible a faulty oil quality sensor,,see what others think
 
OP
xavierx

xavierx

Senior Member
Joined
Sep 16, 2009
Messages
237
Reaction score
0
Your Mercedes
2004 W211 E320 CDi
  • Thread Starter
  • Thread starter
  • #3
Hi Guys and gals,

It is doing it every time I drive the car.

Miles to service is now starting at around 12,200, after driving a mile it jumps to saying 7500KM to service (note KM not MILES)

If I flick through the pages on the computer using the steering wheel buttons, and then back to the miles to service page... it then says 7500MILES (note MILES this time) to service.

Any ideas? Services are expensive enough without having to have one early :(

Thanks in advance
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Either the cluster or the sensor,,as it is miss reading more like the cluster
 
OP
xavierx

xavierx

Senior Member
Joined
Sep 16, 2009
Messages
237
Reaction score
0
Your Mercedes
2004 W211 E320 CDi
  • Thread Starter
  • Thread starter
  • #5
I went into the main dealer in Blackpool today to show them the fault. An engineer came out to my car and said he had never seen this fault before. He said he guesses that it is loosing its oil quality setting and hence dropping to a lower oil. I suggested that it might be the oil quality sensor and he said no, its probably the cluster.

They then asked me to re-mortgage my house to pay to connect my car up to their Star diagnostics .... so I think I will decline.

Who would be the cheapest for Star diagnostics in the Blackpool/Preston area?

Unfortunately I was spoilt by every single other car I have owned, as I have never had to pay for plugging into the diagnostics in my life ... whether that be main dealer or independant :eek:

Thanks for your help
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
At least he said what I said so they cant be too bad :rolleyes::rolleyes:

We will find somewhere for you
 

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
5,877
Reaction score
1,326
Location
Reading
Your Mercedes
Smart + others :)
I agree, most likely cluster, if it was just oil sensor, it would not swop from miles to km??
 
OP
xavierx

xavierx

Senior Member
Joined
Sep 16, 2009
Messages
237
Reaction score
0
Your Mercedes
2004 W211 E320 CDi
  • Thread Starter
  • Thread starter
  • #8
Is there anything that can be done to he cluster? Like reflashing or resetting it? I don't think i could justify the cost of a replacement cluster (I am guessing £000's)when it is working 99.9%

Thanks in advance
 
OP
xavierx

xavierx

Senior Member
Joined
Sep 16, 2009
Messages
237
Reaction score
0
Your Mercedes
2004 W211 E320 CDi
  • Thread Starter
  • Thread starter
  • #9
I took the car into Ian Walker at 124 Works and he spent a considerable ammount of time with my car plugged into Star doing various tests, resetting the cluster etc, but unfortunately the problem still exists and no faults related to the cluster are showing.

Oil quality value is 2.0 (valid values are 1.5 - 4.0) so I guess that indicates that the oil quality sensor is operating within specification.

Ian has kindly offered to have a further play about another day and see if he can find anything to cure the problem. Does anyone else have any ideas?

I would also like to add that it was a pleasure to meet Ian and his assistant, who were both friendly and helpful. I would say that based on my experience today, I would be happy to take my car to them for both routine servicing and repairs.
 
A

andy@pcd-ltd

Guest
Dont want to throw a spanner in the works but the assyst settings is also controlled by the central gateway.

So it could also be this that is causing the problem
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
but could the cgw change the distance remaining from miles to km??
 
A

andy@pcd-ltd

Guest
I may well do i have had them before where they dont either reset or once they do reset and the mileage is wrong the only way we could get round it was to replace the cgw. We did try a loan icm in it but that didnt work but im not saying its not the icm it could well be but who knows with these cars they like to keep us on our toes
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
who knows indeed! and when i tell them i need to get it on the computer, my customers say "and that will tell you what is wrong". i wish it did.
 
A

andy@pcd-ltd

Guest
yeah i think some customer think the star machine we have is a magic machine and will tell us instantly what is wrong with the car
I too wish it was that easy
 
OP
xavierx

xavierx

Senior Member
Joined
Sep 16, 2009
Messages
237
Reaction score
0
Your Mercedes
2004 W211 E320 CDi
  • Thread Starter
  • Thread starter
  • #15
I think the "KM" problem is a red herring. If I switch pages and then back to the miles to service page (when it was previously displaying KM) it then displays miles correctly (but still 7000 instead of 12000)

After having to demonstrate the fault so many times now, I can give an accurate picture of what is happening ....

1) Insert key, display miles to service. Display will read aprox "Service D in 12000 miles"

2) Wait aprox 1 minute and the display will change to showing "Service D in 7500 miles" or "Service D in 7500km"

3) If it is showing km instead of miles, flick to another page and then back to miles to service will display "Service D in 7500 miles"

4) Turning off the ignition, waiting a couple of minutes and then turning back on results in the message "Service D in 12000 miles" .... GOTO step 2 and repeat


I am almost certain that the problem is related to oil quality / oil quality settings

1) The car was serviced aprox 2400 miles ago. Therefore 12000 miles to Service D is a perfectly normal Assyst+ interval to be remaining as the car is doing motorway miles. Car was last serviced by Mercedes and the bill says low ash 229.5 oil

2) When the car switches to saying 7500 miles to service D, that is almost exactly like it is counting down from 10,000 miles since the last service. I assume that this would be triggered if the car was set to having being filled with non-long life oil or if the oil quality sensor was detecting extreme contamination?

The Mercedes dealer technician suggested that his best guess was that it was loosing the oil quality setting.

Knowing exactly which module stores oil related settings I guess would be a good start.

Kind regards
 

AIB understand your special Mercedes deserves a special insurance policy. We have a refreshing attitude to insuring high performance, modified, imported or classic and vintage cars and deal with the UK’s leading insurers. We offer discounts for length of ownership, where the vehicle is kept overnight and limiting the mileage and can also cater for those clients who need higher mileage and business use. To obtain a quotation please call the team on 02380 268351 or visit us atAIB Insurance
Top Bottom