misfire on no.1 cyl c200komp 2003

podmo

Senior Member
Joined
Oct 8, 2009
Messages
59
Reaction score
0
Location
newcastle
Your Mercedes
2003 c200 komp,2002 audi a4 2.5tdi
hi all having just re done the head on my c200 komp it not running all that well, the chap across the road stuck a code reader on it and it came up with misfire on no.1 cylinder, now there are 4 brand new coil packs on the car and i was wondering if anybody has any ideas as to what i could check to remedy this? im wondering if with me taking the head off which included taking many hoses,fuel rail,sensors ect i may have disturbed something? its the 271 engine, many thanks :)
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
Do a search for sticky valves = or was this what the head was off for?.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Why not change the coil pack over to another place and try it
 
OP
P

podmo

Senior Member
Joined
Oct 8, 2009
Messages
59
Reaction score
0
Location
newcastle
Your Mercedes
2003 c200 komp,2002 audi a4 2.5tdi
  • Thread Starter
  • Thread starter
  • #4
yes richard,i took the head of to replace all the inlet valves
 
OP
P

podmo

Senior Member
Joined
Oct 8, 2009
Messages
59
Reaction score
0
Location
newcastle
Your Mercedes
2003 c200 komp,2002 audi a4 2.5tdi
  • Thread Starter
  • Thread starter
  • #5
Why not change the coil pack over to another place and try it

yes malcom il try that tommorow, maybe its just a faulty one from new or a spark plug is faulty
 

busby20

Active Senior Members
Joined
Mar 22, 2007
Messages
223
Reaction score
0
Location
Glasgow
Your Mercedes
SLK's 2, CLK320 Cabriolet.
Why not change the coil pack over to another place and try it
Had a similar problem a while ago with my old C180, specialist couldn't find the fault, however, another garage used the older "Sun" type oscilliscope type and discovered it was one of the "new" coil packs that I had fitted previously, it was malfunctioning and causing an intermittent misfire. Suppose the moral is, just because it's new doesn't mean it aint faulty!
 
OP
P

podmo

Senior Member
Joined
Oct 8, 2009
Messages
59
Reaction score
0
Location
newcastle
Your Mercedes
2003 c200 komp,2002 audi a4 2.5tdi
  • Thread Starter
  • Thread starter
  • #7
Had a similar problem a while ago with my old C180, specialist couldn't find the fault, however, another garage used the older "Sun" type oscilliscope type and discovered it was one of the "new" coil packs that I had fitted previously, it was malfunctioning and causing an intermittent misfire. Suppose the moral is, just because it's new doesn't mean it aint faulty!

yes il swap them about and see what comes up,im kind of hoping it is a faulty one just to make things easy for a change,the car is of road at the moment so cant take it to get put on diagnostic jobby, im thinking of checking coils,plugs,fuel injectors/leads as there the parts i have had off, after that im in no mans land ,not got an igloo what to look at after that
 

busby20

Active Senior Members
Joined
Mar 22, 2007
Messages
223
Reaction score
0
Location
Glasgow
Your Mercedes
SLK's 2, CLK320 Cabriolet.
yes il swap them about and see what comes up,im kind of hoping it is a faulty one just to make things easy for a change,the car is of road at the moment so cant take it to get put on diagnostic jobby, im thinking of checking coils,plugs,fuel injectors/leads as there the parts i have had off, after that im in no mans land ,not got an igloo what to look at after that

Go back to basics, i.e. Fuel+Air+Compression+Timing+Ignition = Power. Sounds simplistic, but if you think about it logically and check the various steps of this sequence there must be a break in the chain - so, if spark is o.k. check fuel, if fuel is o,k. check air, etc.etc. got to be there somewhere ;);)
 
OP
P

podmo

Senior Member
Joined
Oct 8, 2009
Messages
59
Reaction score
0
Location
newcastle
Your Mercedes
2003 c200 komp,2002 audi a4 2.5tdi
  • Thread Starter
  • Thread starter
  • #10
i will do busby,ive just swaped the plug and coil to no. 2 cyl and will see if its swapped the misfire to that one,just waiting for a code reader of the chap over the road,im sure as i go through the list i will come across the cause,

yes blackc55 il do a compression test today,ive done the valves so maybe there is a fault with one
 
OP
P

podmo

Senior Member
Joined
Oct 8, 2009
Messages
59
Reaction score
0
Location
newcastle
Your Mercedes
2003 c200 komp,2002 audi a4 2.5tdi
  • Thread Starter
  • Thread starter
  • #11
just an update, changed two coil packs round and it still sounded like it was missing, however,went to start it again 30 mins later and it has cured itself,dont know how but im not complaining, maybe it was a loose conection,

thanks for all your input gents
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
sorry podmo. the missing is due to the ecu shutting down one or more cylinders. it will do this at the drop of a hat, because it detects cylinder misfires over a certain threshold that you may not even notice! often 'turning it off and on again' will reset it for a while. did you grind the valves in?
 
OP
P

podmo

Senior Member
Joined
Oct 8, 2009
Messages
59
Reaction score
0
Location
newcastle
Your Mercedes
2003 c200 komp,2002 audi a4 2.5tdi
  • Thread Starter
  • Thread starter
  • #13
sorry,have been away on a jolly, yes i ground all the valves in so they were well seated,had a good test drive in it and withought problem,its running very smooth now,i will have to keep an i on it and see if it happens again
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
could be the split hose you may have read about - do you have a code scanner?
 
OP
P

podmo

Senior Member
Joined
Oct 8, 2009
Messages
59
Reaction score
0
Location
newcastle
Your Mercedes
2003 c200 komp,2002 audi a4 2.5tdi
  • Thread Starter
  • Thread starter
  • #15
had a code scanner which the chap over the road plugged in,just came up with missing on no.1, still seems fine now, il just have to wait and see if it happens again,which im sure it will but you never know
 

newusermb

Member
Joined
Nov 7, 2009
Messages
18
Reaction score
0
Hi there,

I got the same problem as Podmo. But my car is C200 Compresor 2002 -engine 111. Is it because of the coil injector?
 


AMF Automotive - We are an independent Mercedes-Benz and AMG specialist located in Dartford, with full Mercedes Diagnostic equipment. We offer a full portfolio of tuning options for AMGs and can cater for all your Mercedes needs.
Tel: 0203 384 4644www.amfmercedes.com/
Top Bottom