ML 270 CDi

luders79

Senior Member
Joined
Jun 13, 2006
Messages
193
Reaction score
0
Location
London
Your Mercedes
W210 estate
Ive got one that intermittently starts, but must of the time It wont even crank over! when it wont start you can tell its going to happen as the suction fan runs on full speed. when it doesnt start no comms with engine ecu and can fault codes in other modules saying no comms with engine! Could it be a power supply probelms to the ecu? would the fan run at full speed if engine ecu is not fully powered up?? If not why would the fan run!

Thanks for any info

Lee
 

Uncle Benz

Senior Member
Joined
Mar 31, 2006
Messages
3,504
Reaction score
2,183
Age
50
Location
West Sussex
Your Mercedes
Mainly Mercedes
Fan command is via CAN, sourced from engine ecu (IIRC...) so it suggests that something is going on with the engine ecu. Worth having a look at the ecu wiring, particularly the earth. Sadly you can't try one from another vehicle, and ecu testing companies can be a bit variable...- but you know that already...

Fan controllers do fail commonly. Might be worth unplugging the small CAN connector from the fan controller and see if it makes any difference, but I think that it's a long shot.
 
Last edited:

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
wel matey, with das we can easily pinpoint the problem with drive authorisation signal test. how do you know the comms faulty? has it been on a diagnostic, if so which one? also does it say `start error` in dash?

this is probably colin's sort of thing, i think he has particular expertise in breakdowns. i do know that they occasionaly have failing AAMs (module/fuse box in engine bay) this could well explain the problem, ecu is easy to check for power supply. also have a seperate D.A.S module which deals with the transponder and cans to AAM then CDI (from memory), these also can fail but do not really fit your symptoms.

so my guess, failed AAM (all activity module). later models also have an EAM (extended activity module) but i don't think this is in the chain.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Does "Start error" come up in the dash
 


Specialist Classic Parts suppliers
SLS Im- & Export Handelsges.mbH, Industriestrasse 2 - 4, D-22885 Barsbuttel (bei Hamburg)
Tel. +49 (0)40 656 939-0, Fax +49 (0)40 656 939-399
Visit our website atwww.sls-hh-shop.deto view our comprehensive catalogue of parts for:
190SL (R121), 230 - 280SL (R113), 280 - 500SL/C (R/C107)
Good English spoken and friendly service to discuss your requirements.
Top Bottom