My new ML320 and its first problem!

PJayUK

Senior Member
Joined
Oct 7, 2008
Messages
281
Reaction score
0
Hi Guys

Its good to be back!

I bought a nice ML320 this weekend as a family runabout. Its got 74K, history and is in nice condition. A real bargain for the price apart from few cosmetic niggles we ae very pleased!

BUT....

Took the car out today and turned on the AC. It doesnt work, just blows luke warm air. I am not getting any clicking noises though so I am hoping and praying its not the air blend motor!

So I was planning to take it in for a regas, which seems like an easy option. I was also wondering if new cabin air filters could help as well. To be honest only having this car for a such a short time I dont know it yet so could use some advice on what to check and any possible solutions.

Cheers guys!
 

panason1c

Senior Member
Joined
Apr 19, 2004
Messages
1,927
Reaction score
6
Age
67
Location
Somerset, UK
Your Mercedes
Mercedes ML270CDI, VW Polo 1.9tdi, BMW K1200RS
I would suggest a regas at Kwik fit @£45 to be your first option, their policy is that if you do have a leak, or the system still doesnt work after the regas, you dont pay anything.
 


Specialist Classic Parts suppliers
SLS Im- & Export Handelsges.mbH, Industriestrasse 2 - 4, D-22885 Barsbuttel (bei Hamburg)
Tel. +49 (0)40 656 939-0, Fax +49 (0)40 656 939-399
Visit our website atwww.sls-hh-shop.deto view our comprehensive catalogue of parts for:
190SL (R121), 230 - 280SL (R113), 280 - 500SL/C (R/C107)
Good English spoken and friendly service to discuss your requirements.
Top Bottom