1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no Crankshaft/ecu communication

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by gothic_merc, May 6, 2013.

  1. gothic_merc

    gothic_merc Active Senior Members

    Messages:
    114
    Likes Received:
    0
    Joined:
    May 6, 2013
    Location:
    Lowestoft
    Your Mercedes:
    w202 cdi estate 1999 2.2, W210 E320 CDI
    Hi. I've a w202 220cdi. Had a warm start issue. Had the crankshaft sensor replaced but star still says there's a communication issue. Would greatly appreciate any advice.

    Other code's were glow plugs and esp

    J
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The CPS measures 800 to 1k ohm when good,, any chance there is a broken wire or poor connection on the CPS
     
  3. OP
    gothic_merc

    gothic_merc Active Senior Members

    Messages:
    114
    Likes Received:
    0
    Joined:
    May 6, 2013
    Location:
    Lowestoft
    Your Mercedes:
    w202 cdi estate 1999 2.2, W210 E320 CDI
    I'll check, I'm not sure where it is but will try tomorrow, thank you for your reply
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    It sits over the starter motor on the bell housing on the starter ring
     
  5. OP
    gothic_merc

    gothic_merc Active Senior Members

    Messages:
    114
    Likes Received:
    0
    Joined:
    May 6, 2013
    Location:
    Lowestoft
    Your Mercedes:
    w202 cdi estate 1999 2.2, W210 E320 CDI
    cool, will it require removing engine cover? I am new to mercedes as a brand and have to say I love it apart from this fault. I want to keep but cant afford repairs that dont solve the issue. once again thanks
     
  6. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    You probably will have to remove the cover
     
  7. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,825
    Likes Received:
    1,003
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    Are you reading the fault codes from STAR?
     
  8. OP
    gothic_merc

    gothic_merc Active Senior Members

    Messages:
    114
    Likes Received:
    0
    Joined:
    May 6, 2013
    Location:
    Lowestoft
    Your Mercedes:
    w202 cdi estate 1999 2.2, W210 E320 CDI
    yeah mate hooked it up. I cant remember exact codes but on the crankshaft sensor it wasn't showing a voltage.
     
  9. OP
    gothic_merc

    gothic_merc Active Senior Members

    Messages:
    114
    Likes Received:
    0
    Joined:
    May 6, 2013
    Location:
    Lowestoft
    Your Mercedes:
    w202 cdi estate 1999 2.2, W210 E320 CDI
    I'll check wiring tomorrow to see if there is anything obvious before taking it back to garage that replaced sensor
     
  10. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,825
    Likes Received:
    1,003
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    Hmmm. It will lose its signal voltage if it can read the sensor. i would check the flywheel for missing/bent teeth. Wouldn't be the first time I have seen that and will produce that very fault code.
     
  11. OP
    gothic_merc

    gothic_merc Active Senior Members

    Messages:
    114
    Likes Received:
    0
    Joined:
    May 6, 2013
    Location:
    Lowestoft
    Your Mercedes:
    w202 cdi estate 1999 2.2, W210 E320 CDI
    Thanks I'll get the cover off tomorrow and have a look
     
  12. OP
    gothic_merc

    gothic_merc Active Senior Members

    Messages:
    114
    Likes Received:
    0
    Joined:
    May 6, 2013
    Location:
    Lowestoft
    Your Mercedes:
    w202 cdi estate 1999 2.2, W210 E320 CDI
    Been told garage replaced cam sensor not crankshaft sensor so will source that this week.
     
  13. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Yes the cam sensor hardly ever fails
     
  14. OP
    gothic_merc

    gothic_merc Active Senior Members

    Messages:
    114
    Likes Received:
    0
    Joined:
    May 6, 2013
    Location:
    Lowestoft
    Your Mercedes:
    w202 cdi estate 1999 2.2, W210 E320 CDI
    I replaced the cps yesterday and the hot start issue remains. This maybe the death of the w202. Shame as was perfect car
     

Share This Page