No power when cold

malatlcb

Active Member
Joined
Mar 7, 2012
Messages
25
Reaction score
0
Location
Leeds
Your Mercedes
Vito Dualiner 3.0cdi 2007 and A class 180 2011, 2003 SLK 200
My 2007 Vito 120cdi auto has a problem when cold. If you try and drive straight away after starting the engine when cold it has no power and is almost like it is in limp mode. If I then turn off the ignition and re start it, it runs fine. Alternatively if I let the engine idle for a few minutes and warm up then it drives spot on. Could it be the turbo sensor?
 

th3h1ghlander

Senior Member
Joined
Mar 23, 2016
Messages
423
Reaction score
140
Location
Chesham
Your Mercedes
C-Class C270 CDI (W203)
My 2007 Vito 120cdi auto has a problem when cold. If you try and drive straight away after starting the engine when cold it has no power and is almost like it is in limp mode. If I then turn off the ignition and re start it, it runs fine. Alternatively if I let the engine idle for a few minutes and warm up then it drives spot on. Could it be the turbo sensor?

Sounds like it could be the Mass Airflow Sensor (MAF), it’s about £75 Bosch part from MB (seriously don’t bother with eBay ones ranging from £25-50). When it is going funny you find you have to power cycle the car to stop it being in limp home mode (no turbo and limited to 2000-2500rpm, you can still get to 70 but takes a while. My MAF would only have the issue when engine warm though but it could have the same issue when cold, at the end of the day if it can’t be read properly the engine management puts itself in safe mode. Before thinking about replacing it, worth checking the connector, unplugging and replugging it, just in case it is just a bad connection. There are other sensors that it could be however I believe this issue is common.


Sent from my iPhone using Tapatalk
 

br0ke

Senior Member
Joined
Jun 2, 2008
Messages
76
Reaction score
8
Location
.
Your Mercedes
2005 CLK 270, 2008 Vito Sport X
The 120cdi needs the more expensive MAF. I know - I just put one in. I also had to get the DPF physically cleaned as it hadn't regen'd in 50k.
Mine isn't particularly good when cold. I was putting it down to the gearbox and I plan on getting that done this year.
 
Top Bottom