1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Non Functioning Heater Motor CLK230 SPORT KOMPRESSOR

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Mr Teddy Bear, Oct 19, 2012.

  1. Mr Teddy Bear

    Mr Teddy Bear Senior Member

    Messages:
    845
    Likes Received:
    2
    Joined:
    Feb 3, 2007
    Location:
    Bristol Between Mill & Cutting
    Your Mercedes:
    1998 W208 CLK 230K SPORT: MG F 1.8VVC: Flame Red Rover 216GTi
    The filter and fan assembly have all been removed. The fan was choked by hedge debris. The fan motor works, however when reassembled the sw isn't talking to the motor.

    Question can this be anything else, apart from the resistor pack that forms part of the assembly, is there a microprocessor interface in there?

    MB want about 240 +vat for this, so don't want to make an expensive mistake!:shock:
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    If the motor runs just fine on 12 volts,,, then either the fuse or reg pack, if the reg pack they can be bought cheap on Ebay, do you have a volt meter
     
  3. OP
    Mr Teddy Bear

    Mr Teddy Bear Senior Member

    Messages:
    845
    Likes Received:
    2
    Joined:
    Feb 3, 2007
    Location:
    Bristol Between Mill & Cutting
    Your Mercedes:
    1998 W208 CLK 230K SPORT: MG F 1.8VVC: Flame Red Rover 216GTi
    Cheers, Malc,
    yes I've got a multi meter.
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    You have 3 wires

    Brown is ground pin 1
    White/ pink is the 0v to 5v feed from the control unit pin2
    Red/blue is the all time live from the fuse pin 3
     
  5. OP
    Mr Teddy Bear

    Mr Teddy Bear Senior Member

    Messages:
    845
    Likes Received:
    2
    Joined:
    Feb 3, 2007
    Location:
    Bristol Between Mill & Cutting
    Your Mercedes:
    1998 W208 CLK 230K SPORT: MG F 1.8VVC: Flame Red Rover 216GTi
    Right this is turning into some thing of a saga now.
    I have bought a refurbished resistor pk from ebay and a new fan motor assy' too.

    I'm told by my mechanic that when fitted that the motor runs even with the ign' key removed. It has been suggested that the system may require some sort of reset. If not that I am guessing that the resistor pack off ebay ain't wired up correctly? as the system worked before.
     

Share This Page